DoP not working

Hello. Wanted to try playing a DSD file via RP4 and Hifiberry DAC+ Pro, via DoP. Looks like it should support either DSD64 or 128, however, when I play the files, I get mostly white noise, almost inaudible. Do I need to select any special settings in Ropiee somehow? From the main window, when I click commit changes, I do see “DoP (DSD over PCM)” set to off, but I don’t see the option to set it to on anywhere?

Am I missing something?

I’m not aware that this device is capable of doing DoP.
The setting you mention is not related to HAT’s.


Not to open a separate topic on this - I just installed RoPieee on а RPi4 connected to my DAC via USB. There is no HAT connected.

I am pretty sure the DoP (DSD over PCM) dropdown was visible on first configuration.

But after I saved the initial configuration, the DoP dropdown is no longer available. Any idea as to why this may happen? When is the dropdown set to be hidden?

Oh, and, after the RPi rebooted, RoPieee is no longer accessible via “ropieee.local” but only via IP. Not sure if related at all.

P.S. Running RoPieee version 2.493 stable - I believe that is the latest one?

For a USB DAC there is no need to configure DoP.
The setting is not meant for this setup and will be removed in the next version to prevent this confusion.

So: DoP should work out of the box, as long as the DAC supports DSD. You can check the settings in Roon. Furthermore you need to make sure you don’t have any form of volume control, because then DSD does not work.

Again, not related to RoPieee. There is nothing that needs to happen inside RoPieee to support DSD: it’s up to the device and the device settings inside Roon.

Thought so.

When configuring the endpoint in Roon, I have set DSD to DoP - that seems to be fine. Just wanted to check why the actual dropdown in RoPieee configuration was not visible anymore, and if that made any difference.

While I have you here, one more quick question - when naming the RoPieee device (Hostname setting), it does not seem to accept characters outside the standard character set (for example “ŵ”) - RoPieee pops up a message saying “Please match the requested format”.

Is that a limitation of the OS, or Roon?

BTW, I am sure you are hearing this a lot, but many thanks for an excellent product and a wonderful out-of-the-box solution.

Actually… neither. This is the hostname of the device, which follows a standard.
That standard describes characters a-z and digits 0-9. Only special character allowed is the ‘-’.


Again, much appreciated for the quick response. :slight_smile: