DSD 512 issue on a 2014 Mac mini [Solved]

For whatever reason, my 2014 Mac Mini is now choking when upsampling hi-res PCM (ie 96 or 192) to DSD 256. Before the update, I was able to upsample hi-res PCM to 2x DSD without a problem. I am still able to upsample hi-res PCM to DSD128, as well as upsample standard redbook PCM to DSD 256. But again, before the update I could get everything to DSD256 successfully. No other recent changes to my system.

I realize this runs counter to what others have described, re: increased efficiency and lower processing load. Any thoughts or suggestions?

Let’s flag @brian and see what he thinks.

Any chance there’s some other stuff going on on the machine or in the background? Check Activity Monitor–maybe something unexpected is hogging the CPU.

Another thought…I use DSD512 upsampling on a dual-core i5 for one of my zones–a tight fit. When I import new content and analysis kicks off, the machine sometimes fails to keep up. For me, keeping Analysis set to “throttled” mostly avoids any issues.

Another thought: you might try turning on “parallelize sigma-delta modulator” to see if it helps.

A final question–can you take a screenshot of your signal path while it’s failing so I can see the processing speed + whatever else you have going on?

Thanks for the feedback @brian

I don’t see anything hogging CPU usage on the activity monitor

“parallelize sigma-delta modulator” didn’t change the problem

here are a couple of screen shots. processing speed seems to be .4-.8x before the song chokes. I honestly dont know what the speed was before the update- I had never looked, because I had never encountered this problem before.

any thoughts?

When this fails, does it fail immediately at the start of playback? A few seconds in? Minutes in? Intermittently? Only with certain content?

Really strange that it’s gotten slower for you. I can’t imagine why that would be.

Always fails about 5 seconds in. Always fails with hi-res PCM (88/96/192). No problems getting redbook PCM to 2x DSD.

I would chalk this up to my Mac Mini not being “robust” enough for the 2x DSD conversion, except it had been working for a few months prior to the upgrade.

After more testing, redbook AND DSF are getting about 2x processing speed when being converted to DSD 128. Mac activity monitor show about 40% CPU usage. When trying to convert hi- res PCM (88/96/192) to DSD 128, however, I only get about .5x processing speed, and the playback fails after about 5 seconds. However CPU usage is only about 55%, so it seems like I still have plenty of headroom?

Is are large PCM files more cumbersome for Roon? Roon is handling the large DSF files without a problem. As previously noted, I was getting PCM -> DSD 128 conversion to work previously.

Update: And after having Roon update to build 218 just now, the redbook and DSF to DSD 128 conversion is now running at about 3x processing speed - yet minimal change in the hi-res PCM conversion issue (now about .5-.6x processing speed).

Any suggestion @brian? Or anyone else?? Thanks!

searching through the support forums, this sounds like a similar (or same) issue:
Build 216 stuttering sound during playing tracks

Any update as to a fix? Thank you!

just bumping this thread in hopes of an answer, as the problem continues to persist.

to recap, when the roon dsp upsampling feature was introduced, i was able to play all file types back at DSD128. at some later time (about when the upgrade to build 216 took place), i was no longer able to upsample hi-res PCM (anything greater than 48) to dsd - and i get the error message above. i do not believe this is a network issue, as i have no problem upsampling large DSD files of equivalent size.

@brian, @andybob, anyone? thank you!

Brian will see your flag and let’s flag @support also. You’ve slipped between the cracks a bit here and I’ll keep an eye on the thread to get it more attention. I’d like to do more but haven’t seen any reports similar to your issue and don’t know enough about Macs to comment.

Can you describe your whole system hardware/software/network ? The first step is often building something similar and seeing if the issue can be replicated.

Any chance Roon has been analysing new tracks when you’ve experienced this ?

1 Like

Hi @jsa307 ----- Thank you for touching base and my apologies for the slow response here.

Moving forward, I would have to agree with Andrew’s post (@andybob :thumbsup:) in regard to having the exact details of your entire setup. Having the exact specs of the 2014 Mac mini hosting your core, a clear understanding of how your devices are communicating (i.e. network config/topology), and insight into how your library is being stored/accessed will greatly help in our evaluation of this behavior being reported.

Looking forward to your feedback!
-Eric

Sure, thanks for the help guys. not sure if this is the right format, but here’s how the data flows:

2 Music folders on QNAP TS-251 (all PCM music in iTunes library folder, DSD in separate folder) -> cat 6 -> trendnet TEG-S82g switch -> Cat 6 -> Router (Fios Quantum Gateway G1100) -> Cat 6 -> Mac Mini

Mac Mini: OS sierra 10.12.3 // i5 2.6 GHz // 8 GB ram - nothing else running on the MAC

Mac -> TEAC UD-503 via USB

please let me know if any other info is needed or helpful, thanks!

Hi @jsa307 ---- Thank you for following up with me and providing the requested feedback. Both are appreciated!

Moving forward, I would like to have you verify some information for me, as well as have you perform a very simple test. Please see below.

Further data gathering…

  1. If memory serves me correctly the Trendnet TEG-S82g switch is unmanaged, but please confirm.

  2. Can you please confirm that jumbo frames are not being used anywhere in your setup.

  3. In your troubleshooting have you tried testing with a different DAC? If so, what was the experience like?

Testing…
Can you please try pulling some hi-res PCM content to the internal storage of the Mac Mini and confirm if you receive the same error message while trying to upsample to DSD.

-Eric

1)unmanaged switch
2)no jumbo frames

same problem when music is played from the local HDD

it took me a few days to have the time to swap out the DAC- when I was able to do that today, i was prompted that build 234 was ready for download. I updated Roon and then tried playback to a different DAC (iFi micro) … everything upsampled to DSD128 without any issue! then I switched back to the TEAC, and again, problem solved … perfect DSD128 upsampling with all files. i continue to believe this is/was a software issue, that began with the build 216 update, and now appears to be corrected. thanks for your help @brian, @andybob, @Eric

1 Like