Dynamic Audio Power Mgt:ON sometimes doesn't work (RoPieeeXL 2022.11.2)


RoPieeeXL 2022.11.2 (0664)
Raspberry Pi 4 Model B Rev 1.5
HIFIBERRY DIGI2 PRO ver 2.2 (newest)
Topping MX5
Connection SPDIF (optical)

I use the Dynamic Audio Power Mgt: ON option because my Topping MX5 amplifiers go into a standby state when activity on the SPDIF link is turned off.
Unfortunately, I can not describe exactly when, but very often my optical connection is not turned off and the amplifier continuously remains on (Mx5 detects activity on the optical link and turns off, I have not had the described problem with other devices - Belkin AirPlay). I have 3 identical configurations and the described problem occurs on each of them. I temporarily solve this problem by turning on the Reboot Schedule (Daily) option, which always turns off the optical link.

Perhaps this post will help improve the next versions.

Regards T.


I know when the problem occurs. Suppose I have two zones Zone1 and Zone2. When I play in Zone1 or Zone2 and stop playback, the signal on SPDIF is turned off correctly. Likewise, if I have two Zone1+Zone2 zones grouped together and I turn off playback, the SPDIF signal is turned off in both zones. The problem occurs when I disconnect the Zone2 zone from the Zone1 zone. Then Zone1 behaves correctly (when stopped, the SPDIF signal is turned off), but Zone2 is stopped when disconnected from Zone1, but the SPDIF signal is not turned off in it.

If I have more zones on RoPieee and they are disconnected from the main zone, then in all disconnected zones the signal on the SPDIF remains active (Dynamic Audio Power Mgt: ON).