Earmen Sparrow - Roopieee

Hi, I’m looking at getting a Cambridge audio DAc magic 200 - however they’re out of stock everywhere here in Denmark until September time. I was at the same time interested in also getting an Earmen Sparrow to use with my iPad and computer when I get back to the office. I was wondering if there were any known reasons why the DAC wouldn’t work with a pi running roopieee as a stop gap in my main system? The alternative would be picking up a second hand DAC to use whilst I wait…

Advice would be great fully received.

Thanks a lot,

Joe

No idea, but I replaced a pricey Cambridge Azur 851 N with this and I am completely happy with it running Ropieee on the integrated Pi4.

Continuing the discussion from Earmen Sparrow - Roopieee:

Hi,

I took the plunge and got the earmen sparrow. As a stop gap until my DAC Magic arrives I wanted to connect it via a Pi running roopieee into my hi-fi. Everything looks like it should be working. However, I momentarily get the screen below showing it connected in Roon and then it disappears from the Roon device lists. I can’t get this to authorise from here.

I’ve used this Pi previously with another Schiit DAC without issue and the lights are flashing as expected on the Pi. Has anyone encountered similar before or have a solution?

The screen shot below shows what appears before it just disappears completely from Roon and isn’t shown at all.

Add images

Can you show pics of the Roopieee config. And for a dumb question, did you follow the setup guide exactly? I know I messed up the name in the Roon control zone portion of the setup once. Is the extension showing correctly?

Hi Craig,

Screen shots below. I’ve just reflashed the SD card and I’ve had exactly the same issue. The first reflash it showed up but as soon as I enabled - it crashed and disappeared from Roon as an option to output.

The DAC is appearing correctly connected with the lights on and when I plug my desk DAC into the Pi it sees and functions correctly with it. I’ve sent a log 110d06a38bef8a1d if someone can look into this?

I’m now really confused @spockfish I don’t know if you’ve ever seen anything like this before but when I’ve then tried the Sparrow on another Pi I have connected on my desk to a Schiit it also disappears from Roon once I try and enable it. When I take the DAC out and replug it in it works once more. I’ve done this with both Pi’s so I’m wondering if this is an issue with the Earmen DAC?

Looking at your logs it seems fine. The DAC is properly recognized, so no issues on the RoPieee side.

I’m wondering if, for some reason, you’ve confused Roon by moving the DAC to another Pi. I also see that you have not named it (in the first screenshot).

My suggestion: start looking on the Roon side. And for me that always begins with a reboot of the Core :wink:

I’m having the same problem - roon bridge on Roopiee briefly detects the EarMen Sparrow - I rename the device via the windows 10 client and hit enter and then the Roon client crashes and Roopiee no longer shows up - a core restart doesn’t help. If I replace the Sparrow with a DragonFly Black and restart everything it works ok again.

FYI, if I plug the Sparrow directly into the Windows 10 PC, roon can use it ok. Only when I connect to the RPi does it crash.

EarMen Eagle does the exact same thing, not surprisingly. I didn’t see this post until after I had tried plugging the Eagle into a RPi4 running RoPieee. Great DAC, wish I could use it with my RPi.