Enabling ARC in Roon 2.0 with Netgear Orbi Router

Upnp is on.

I’ve manually set port forwarding connecting port 55000 to 192.168.1.28 (the location of the ROCK server on my LAN).

My Plex server is working just fine. Remote access is no problem.

Here is the error message:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 195.252.198.182:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“195.252.198.182”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

What should I do to fix this problem?
}

The router says the IP address is:

100.91.68.59 

Is ARC looking to a different IP address?

How have you got your Orbi gear setup in relation to Roon Core and endpoints?

So I run Plex and ARC on two different server’s and both work perfectly.
Is the router connected to Orbi as a modem or are you running double NAT?

Settings as below in Orbi

2 Likes

Regarding your Orbi setup. WiFi or wired backhaul?

If WiFi, in the settings, is your daisy-chain topology enabled or not.

Quite a few Orbi owners are having issues.

Yes. Roon is working fine on my LAN.

Mine is WiFi backhaul with the Roon core wired into an an AP

Are people who are having this problem mostly running in AP mode rather that router mode, or is it both?

Thanks for your willingness to help. I have the port forwarding set up as it shows on your screen, using the LAN port assigned to my ROCK.

The router is set up as the modem connected to a fiber optic ONT (the drop point for my ISP).

The error message is too cryptic for me to troubleshoot. I’ve done a posting in the Support section in hopes that the Roon staffers can decrypt it for me.

There is nothing in the error message matching the external IP address for my network.

It’s all ethernet. No WiFi

Julian so you are running in router mode and in that case everything should be good.
Do you also have UPNP disabled?

Not to sure. With my Ubiquiti setup I had issues if Core was connected to AP and endpoint connected to my UDR. My APs are wired backhaul as they are POE. Once connected all to my UDR many of my issues went away. This was prior to Roon ARC as well.

It could help those with issues if you did a step by step set up process

Not sure about others.

I suspect the ARC may be misreading the external IP address of my network.

The port forwarding should avoid firewall issues.

I thought there was already one for Orbi routers.

Always different scenarios but mine was working very quickly using those rules.

I have also always had UPNP disabled as I have never liked it due to poor implementations

1 Like

Thanks Michael.

I tried it with Upnp disabled and activated. Did not work in either mode.

Seems like the ARC is getting hung up before it reaches my router address. The error message contains an address to an upstream hub of my ISP, not my external IP address.

Is your ISP providing CGNat?

I’ve got an Orbi (RBR50) router (Firmware Ver V2.7.4.24) connected via wired ethernet to an Orbi (RBS50 - same firmware version as router) satellite in the other end of the house.Then wired ethernet from the satellite to Etherregen then SFP fiber optic to my Lumin X1 streamer. All is working well with Arc since launch. No problems to report. Didn’t have to do anything other than upgrade to Roon 2.0 and the installation process took care of the UPNP configuration on the router with Arc. Not that it probably makes any difference but might be work checking that you have the latest firmware installed on the Orbing gear.

1 Like

Just here to mention my Orbi (RBR850) is setup and working fine with Roon ARC. In the following configuration:
Router mode
UPnP disabled - preferable for security reasons (I believe)
Port Forwarding… however Roon gave me a much more random port number 59659 rather than 55000 which was mentioned in one of their support articles.

1 Like

Julian during testing there were a lot of initial issues with ISPs and Routers having problems. Sadly it was always going to take a long time to build this information out from the Roon side. Even though there were several hundred of us involved in the early testing and many more in the later beta there are just so many variables.

Have you contacted your ISP yet, as as Rugby mentioned you might be behind a CGNAT set-up where the real IP address is actually further along the line. If so there might be some options where they can offer upgraded service at a costume.