Endpoint syncing - lots of posts, no solutions from staff?


(Brian Luczkiewicz) #11

Sonos integrates many services, yes, but they do it in a very simplistic way. Services are not fully integrated with or blended into your library. Each lives in its own ghetto, and you can browse them with a very basic list-based mechanism.

Our approach–seamlessly blending your content with content from services, and allowing for the same ownership-like experience for streaming and local content–is significantly more ambitious.

It is important to us to line up at least one other streaming service, so that we are not solely reliant on TIDAL. It will have to be lossless to make sense with such a quality-focused product–which limits the options. This is an area where we’re actively working, but not a fast process. The technical/data pre-requisites that are required to accomplish our style of integration are more than these companies are accustomed to providing, plus many of the most popular streaming companies (Spotify, Pandora notably) do not like to work with others on stuff like this at all.

We don’t share ETA’s until work on a project is substantially done and into alpha testing. Too many variables or opportunities to change plans or re-prioritize. It just leads to disappointment.

This is coming for TIDAL. Work is underway.


(Brian Luczkiewicz) #12

That was what the “unable” in “unable or unwilling” was all about :slight_smile:

The “unwilling” ones are cases where the manufacturer could have reported correctly, but didn’t (USB DACs).


#13

Ok, you’re way ahead of me! Looking forward to seeing this resolved.


(Daniel Beyer) #14

Don’t see it as a systemic Android problem, might be a galaxy S5 problem. After reading your posts I put a Note 3, a Note 4 and a Note 5 and a desktop in a group and played them for 6 hours straight with no syncing issues at all.


(Garrett Williams) #15

I run Roon core on a Windows 10 computer, and not much else (Plex, anti virus, etc). Media is ripped from CDs and stored as FLAC files. I use a Samsung Galaxy S7 Edge, Samsung Galaxy Tab Pro, Windows desktop to control Roon playback. My endpoints are a Bryston BDP-2 and the above listed devices as well as the Samsung Galaxy S5. Everything is stock (no rooted phones, alternative boot loaders, etc.) Everything that can be connected via wired ethernet is. The wifi router is within 10 feet and 2 walls of everything in question, providing quite a good signal. The local network is 5GHz in 802.11AC with little other traffic and excellent signal strength.

Please let me know if you need other info. I’ll try to test this again with one of my other wired devices early next week in case the issue is localized to the S5.


(Daniel Beyer) #16

An interesting experiment would be to try putting only the two or three samsung galaxy devices in a group, playing the audio out the devices speakers (ile not restreaming to a bluetooth speaker), and see if they stay in sync. Which is what I did,.


(Ed Davey) #17

I’ve been experimenting with multi-room playback of ‘regular’ audio files: flac and mp3 format files (44.1 kHz / 16 bit) with mixed results.

Setup

In my home I’ve set up a ‘downstairs’ group as follows:

kitchen

  1. Windows 7 running Roon core and playing via ‘system output’ thru a Behringer USB DAC into a stereo amp and speakers

sitting-room

  1. Windows 7 running Roon remote and playing thru a Cambridge Audio USB DAC
  2. RaspberryPi 3 with HifiBerry DAC+ running their 1.0.4 Roon image

[2] and [3] are connected to different inputs on a stereo amp.

Results

Positioned in the sitting-room with the door open, so that I can hear the kitchen audio too, when listening to:

  • [1] & [2] the two Windows systems are in perfect sync,
  • [1] & [3] the Windows and RaspberryPi are out of sync

I was initially delighted by the first result [1] & [2] which is something I’ve been unable to achieve with JRiver zones, but the promised land of [1] & [3] seems still out of reach: sending synched music to a dumb, cheap, dedicated endpoint.

Conclusions

I’m just a novice with Roon, but it would seem that:

  • the poor syncing between [1] and [3] is a function of device-specific implementation differences rather than network latency

  • the specific solution for getting my RaspberryPi in sync with Windows is either:

    a) correcting any implementation error in the HifiBerry Roon image. If the HifiBerry DAC+ is

‘unable or unwilling to accurately report downstream output delays’

then is that a bug that the HifiBerry DAC+ Roon image maintainer can fix?

b) adjusting the timing of this particular node in the setup of the Roon ‘group’ – and I understand that this kind of timing adjustment is a planned feature.

I hope this is helpful as, for me at least, reliable multi-room playback is a critical feature.

thks

Ed


(Geoff Coupe) #18

@Ed_Davey, prompted by your experiments, I thought I’d do one of my own. For some reason, I’m not getting sync problems (at least so far).

Setup
See here. For the purposes of the experiment, I had the microRendu connected to the QUAD HiFi, and repurposed the RPi3+ IQaudIO Pi-DAC+ as a headphone driver. The RPi is using WLAN.

I grouped the following endpoints into a single zone:

  1. Desktop PC running Windows 10 (ethernet connected)
  2. microRendu + Dragonfly v 1.2 driving QUAD HiFi system
  3. RPi3 (WLAN connected) + IQaudIO Pi-DAC+ driving headphones
  4. RPi2 (ethernet connected) + HiFiBerry DIGI+ driving Denon 3808

The RPi+Pi-DAC+ is using the RC4 version of the Roon sw from IQaudIO, while the HiFiBerry is using version 1.0.3 of the sw.

All controlled via Windows 10 laptop using Roon Remote (using FLAC 44.1 kHz 16bit files)

And… no sync problems…


Too Many Dropouts - Killing Stream
#19

I have two pi3s and a Windows 10 PC all running Roonbridge and they sync ok. I have a few times found them getting out of sync but a reboot solved things.

Try Roon bridge on the Windows 7 machine if you are not already doing that. Seems like you are past the time for the free upgrade to Windows 10. I don’t have any firm evidence but I think this has been better since I took the plunge and upgraded from win7 to win10 recently. My core is on another machine like yours that has been running Windows 10 for a while so I did have two different versions of Windows for a while.


(Geoff Coupe) #20

I would add that I am getting (after an hour or two) instances of tracks stopping playback, and Roon skipping to the next track. Playback remains in sync across all zones - it’s just that Roon is reporting “Too many dropouts” in the stream, thus it stops the currently playing stream and moves on to the next track, e.g.:

[code]
08/16 17:28:46 Info: [zoneplayer/base] Playing: D:\Music\Janet Jackson\janet\17 Because of Love.flac
08/16 17:28:46 Info: [zoneplayer/base] Queueing: D:\Music\Craig David\Slicker Than Your Average\05 Eenie Meenie.flac
08/16 17:28:46 Info: [zoneplayer/base] Open Result (Playing):Result[Status=Success]
08/16 17:28:46 Info: [zoneplayer/base] Starting playback
08/16 17:28:46 Trace: [zoneplayer/raat] StartStream StreamFormat(channels=2, bitspersample=16, samplerate=44100, isdts=False streamid=1501629369
08/16 17:28:46 Trace: [zoneplayer/raat] _StartStream2 streamid=1501629369
08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=1000 Quality=Lossless
Raat Device=HiFiBerry Digi+
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Digital Quality=Lossless

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=1000 Quality=Lossless
Raat Device=Sonore microRendu
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Usb Quality=Lossless

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=1000 Quality=Lossless
Raat Device=High Definition Audio Device
Output OutputType=Local_ExclusiveMode_Wasapi Quality=Lossless

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=1000 Quality=Lossless
Raat Device=IQaudIO DAC/DigiAMP
Output OutputType=Local_Analog Quality=Lossless

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=1000 Quality=Lossless
Raat Device=HiFiBerry Digi+
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Digital Quality=Lossless

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=1000 Quality=Lossless
Raat Device=Sonore microRendu
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Usb Quality=Lossless

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=1000 Quality=Lossless
Raat Device=High Definition Audio Device
Output OutputType=Local_ExclusiveMode_Wasapi Quality=Lossless

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=1000 Quality=Lossless
Raat Device=IQaudIO DAC/DigiAMP
Output OutputType=Local_Analog Quality=Lossless

08/16 17:28:46 Trace: [transport/raatclient] GOT [3282] {“status”:“Success”}
08/16 17:28:46 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/261 sec
08/16 17:28:46 Trace: [transport/raatclient] GOT [3031] {“status”:“Dropout”,“samples”:7056}
08/16 17:28:46 Warn: [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream
08/16 17:28:46 Trace: [zoneplayer/raat] too many dropouts. stopping stream
08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Inactive
Elements:

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Inactive
Elements:

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Inactive
Elements:

08/16 17:28:46 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Inactive
Elements:

08/16 17:28:46 Warn: Track Stopped Due to Slow Media
08/16 17:28:46 Trace: [raat/audiosource] got NAK (15 seqs, 15 satisfied is_max=True)
08/16 17:28:46 Info: [zoneplayer/base] Playing: D:\Music\Craig David\Slicker Than Your Average\05 Eenie Meenie.flac
08/16 17:28:46 Info: [zoneplayer/base] Queueing: D:\Music\The Pointer Sisters\Legends\CD3\09 Moonlight Dancing.flac
08/16 17:28:46 Info: [zoneplayer/base] Open result (Queueing): Result[Status=Success]
08/16 17:28:46 Trace: [transport/raatclient] GOT [3258] {“status”:“Success”}
08/16 17:28:46 Trace: [raat/audiosource] got NAK (15 seqs, 15 satisfied is_max=True)
08/16 17:28:46 Trace: [transport/raatclient] GOT [57] {“status”:“Success”}
08/16 17:28:46 Trace: [transport/raatclient] GOT [3031] {“status”:“Dropout”,“samples”:5292}
08/16 17:28:46 Warn: [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream
08/16 17:28:46 Trace: [zoneplayer/raat] too many dropouts. stopping stream
08/16 17:28:46 Trace: [raat/audiosource] got NAK (15 seqs, 15 satisfied is_max=True)
08/16 17:28:46 Trace: [transport/raatclient] GOT [3031] {“status”:“Dropout”,“samples”:3528}
08/16 17:28:46 Warn: [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream
08/16 17:28:46 Trace: [zoneplayer/raat] too many dropouts. stopping stream
08/16 17:28:46 Trace: [raat/audiosource] got NAK (15 seqs, 15 satisfied is_max=True)
08/16 17:28:47 Trace: [transport/raatclient] GOT [3031] {“status”:“Dropout”,“samples”:5292}
08/16 17:28:47 Warn: [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream
08/16 17:28:47 Trace: [zoneplayer/raat] too many dropouts. stopping stream
08/16 17:28:47 Info: [zoneplayer/base] Open result (Queueing): Result[Status=Success]
08/16 17:28:47 Info: [zoneplayer/base] Open Result (Playing):Result[Status=Success]
08/16 17:28:47 Info: [zoneplayer/base] Starting playback
08/16 17:28:47 Trace: [zoneplayer/raat] StartStream StreamFormat(channels=2, bitspersample=16, samplerate=44100, isdts=False streamid=1501629370
08/16 17:28:47 Trace: [zoneplayer/raat] _StartStream2 streamid=1501629370
08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=934 Quality=Lossless
Raat Device=HiFiBerry Digi+
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Digital Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=934 Quality=Lossless
Raat Device=Sonore microRendu
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Usb Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=934 Quality=Lossless
Raat Device=High Definition Audio Device
Output OutputType=Local_ExclusiveMode_Wasapi Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=934 Quality=Lossless
Raat Device=IQaudIO DAC/DigiAMP
Output OutputType=Local_Analog Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=934 Quality=Lossless
Raat Device=HiFiBerry Digi+
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Digital Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=934 Quality=Lossless
Raat Device=Sonore microRendu
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Usb Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=934 Quality=Lossless
Raat Device=High Definition Audio Device
Output OutputType=Local_ExclusiveMode_Wasapi Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=934 Quality=Lossless
Raat Device=IQaudIO DAC/DigiAMP
Output OutputType=Local_Analog Quality=Lossless

08/16 17:28:47 Trace: [raat/audiosource] got NAK (15 seqs, 15 satisfied is_max=True)
08/16 17:28:47 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/304 sec
08/16 17:28:47 Trace: [zoneplayer/raat] synced to endpoint clock. realtime=1047255460560 rtt=50us offset=-5392127251us delta=-5392127251us
08/16 17:28:47 Trace: [zoneplayer/raat] synced to endpoint clock. realtime=6467791366692 rtt=850us offset=28408654us delta=28408654us
08/16 17:28:47 Trace: [zoneplayer/raat] synced to endpoint clock. realtime=6466632892120 rtt=1000us offset=27248676us delta=27248676us
08/16 17:28:47 Trace: [transport/raatclient] GOT [3031] {“status”:“Dropout”,“samples”:3528}
08/16 17:28:47 Warn: [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream
08/16 17:28:47 Trace: [zoneplayer/raat] too many dropouts. stopping stream
08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Inactive
Elements:

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Inactive
Elements:

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Inactive
Elements:

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Inactive
Elements:

08/16 17:28:47 Warn: Track Stopped Due to Slow Media
08/16 17:28:47 Info: [zoneplayer/base] Playing: D:\Music\The Pointer Sisters\Legends\CD3\09 Moonlight Dancing.flac
08/16 17:28:47 Info: [zoneplayer/base] Queueing: D:\Music\Tina Turner\Break Every Rule\06 Girls.flac
08/16 17:28:47 Info: [zoneplayer/base] Open Result (Playing):Result[Status=Success]
08/16 17:28:47 Info: [zoneplayer/base] Starting playback
08/16 17:28:47 Trace: [zoneplayer/raat] StartStream StreamFormat(channels=2, bitspersample=16, samplerate=44100, isdts=False streamid=1501629371
08/16 17:28:47 Trace: [zoneplayer/raat] _StartStream2 streamid=1501629371
08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=841 Quality=Lossless
Raat Device=HiFiBerry Digi+
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Digital Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=841 Quality=Lossless
Raat Device=Sonore microRendu
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Usb Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=841 Quality=Lossless
Raat Device=High Definition Audio Device
Output OutputType=Local_ExclusiveMode_Wasapi Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=841 Quality=Lossless
Raat Device=IQaudIO DAC/DigiAMP
Output OutputType=Local_Analog Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=841 Quality=Lossless
Raat Device=HiFiBerry Digi+
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Digital Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=841 Quality=Lossless
Raat Device=Sonore microRendu
DigitalVolume GainDb=0 Quality=Lossless
Output OutputType=Local_Usb Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=841 Quality=Lossless
Raat Device=High Definition Audio Device
Output OutputType=Local_ExclusiveMode_Wasapi Quality=Lossless

08/16 17:28:47 Info:
–[ SignalPath ]---------------------------------------------
SignalPath Quality = Lossless
Elements:
Source Format=Flac 44100/16/2 BitRate=841 Quality=Lossless
Raat Device=IQaudIO DAC/DigiAMP
Output OutputType=Local_Analog Quality=Lossless

08/16 17:28:47 Info: [zoneplayer/base] Open result (Queueing): Result[Status=Success]
08/16 17:28:47 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/295 sec
08/16 17:28:47 Trace: [raat/audiosource] got NAK (15 seqs, 15 satisfied is_max=True)
08/16 17:28:47 Trace: [transport/raatclient] GOT [3031] {“status”:“Dropout”,“samples”:1764}
08/16 17:28:47 Warn: [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream[/code]

This is an issue, but it’s different from the “not in sync” issue… I’ll raise it separately…


Too Many Dropouts - Killing Stream
(Ed Davey) #21

Thanks folks!

@Geoff_Coupe: thanks for your feedback. The only real differences I see in our experiments are:

  1. Windows 7 at my end vs. Win 10 in your system. But as @philr says I’ve missed the boat for that free Win 10 upgrade!

  2. I have the HiFiBerry DAC+ on a RP3 as opposed to your RP2

@philr: are you suggesting running Roon Bridge on [1] the machine running Roon Core? That might improve the synchronisation between it and the RaspberryPi? Or perhaps you misunderstood my issue? The sync between the Windows machines [1] & [2](Core and Bridge) is good. It’s between the Windows machine running Core and the RaspberryPi running Bridge [1] & [3] which is problematic…

@Geoff_Coupe: regarding the skipping after prolonged playback, that is certainly not my issue. The sync issue I have is consistent: it’s there from the get-go. When I pause I hear the kitchen play on for maybe 1/4 sec before pausing. When I resume playback the delay is there again.

I’m on the road at present but once I’m back home tomorrow I will have another play…

thanks

Ed


#22

I believe that you hit it on the nail and that it is a Windows 10 issue.

Roon is a network driven streaming program and is very good at it. However there are many stories out there about the amount of Network Traffic that Windows 10 adds to any network. As a matter of fact the more that there are Windows 10 PC’s on a network the more congested network activity there is.

Windows 10 is constantly phoning home to over 30 different servers for what that say is telemetry reasoning. Also Windows 10 Updates have been changed from the normal Direct from you to Windows Update Server to a Torrent Update Service. Bottom line, Windows 10 is network hog.


(Geoff Coupe) #23

Er, except that Ed was having sync problems with Windows 7, and I’m not with Windows 10, so rather the opposite to what you seem to be suggesting.

I don’t doubt that Windows 10 is more chatty, but I don’t think this is an issue, particularly over a wired home network.

Where there does seem to be an issue is RAAT running over 802.11n WiFi. I’m consistently seeing skipping and dropouts here (with a RPI3, and with no other Windows 10 system using WiFi). Running RAAT over 802.11ac is much better, and wired endpoints carry on regardless…


#24

I would think that Windows 10 as a client would probably be ok, but as a server I wonder.

I am really curious how many users are using Windows 10 as a Server and what kind of success that they are having.

I am new to this forum. Is there a survey section?


(Geoff Coupe) #25

I have an Intel NUC6i3SYH running Windows 10 Pro. More than enough for my Roon library (20,000 tracks) and running our Home Automation system (Domoticz).

By a “survey section” - do you mean what setups people are using for Roon? If so, then this is the thread to read.


(Ed Davey) #26

To follow up, now that I’ve had a chance to play around a bit more I can confirm that I can reliably reproduce the issue: Win7 <-> Win7 players sync correctly but I have a lag between Win7 and RP3-HifiBerry+

Other possible experiments: I could:

  1. try Win10 rather than Win7 on the Core machine. A bit of an expensive test.

  2. try an RP2 with a USB wireless adapter rather than the RP3 with its built in wireless. Anyone in the UK able to lend me RP2 for a quick test?

  3. try the IQAudIO Pi-DAC+ on my RP3 rather than the HifiBerry DAC+. Anyone in the UK got one spare I could borrow for a test?

Thanks

Ed


(Rene Bouwmeester) #27

I don’t normally run grouped zones, but for testing I ran a group of three:

  • Pi2/Digi+, wired
  • Pi3/IQ Audio DAC+, wireless
  • MacBook Pro w/Roon Bridge, wireless

It has been playing happily and fully synced for a few hours now.

That said, I do have excellent WiFi reception on non-congested channels, and both the Pi3 and the MacBook are within 5 meters and in line of sight of the access point (last-gen Airport Extreme).

Your lag has the smell of bad Wifi latency (could be the Pi, your network or both). Can you tell a bit more about your network (router/access point, Wifi speed, extenders in use)?

And could you – just for troubleshooting – temporarily run a wired network connection to your Pi and see if the lag is still there?


(Ed Davey) #28

@RBM thanks for this, but actually I think my tests suggest the opposite – that it’s not network latency. I have two Roon Bridges set up next to each other in my sitting room:

  1. Windows 7 over wifi
  2. RP3 with HifiBerry DAC+ over wifi

The Windows 7 Bridge [1] works perfectly: the audio in the kitchen is reliably in sync with the audio in the sitting room. Whereas the RP3 Bridge [2] is reliably out of sync with the kitchen. It’s consistently about 1/4 of a second ahead of the Core machine in the kitchen, producing a nasty ‘echo’ effect.

So I think my original question stands: is this either:

a) a bug in HifiBerry’s implementation which it is reasonable or realistic to expect them to fix, or

b) is it a function of inevitable differences in hardware which it is only possible to overcome with a Roon work-around in the form of configurable timing adjustments to individual nodes in a zone or ‘group’?


(Geoff Coupe) #29

@Ed_Davey, it appears as though (for both myself and @RBM) an RPi with a HiFiBerry Digi+ is in perfect sync with all other endpoints, but that an RPi with a HiFiBerry DAC+ is not. That seems to me to point to a strong possibility that it’s an issue with the HiFiBerry software…


(Rene Bouwmeester) #30

Hi Ed,

Wiring it all up is just a quick little test to rule out any unpredictable nasties WiFi may cause. It never hurts. :slight_smile:

As for a): have you tried installing Raspbian + Roon Bridge manually? (Little guide if necessary). This may (or may not) rule out any weirdness in the Hifiberry image (I2S DACs are not expected to have any latency).

And for b): I very much doubt whether the DAC+ should need a delay, but a future Roon release will have timing/delay setting for endpoints that cannot/will not convey this information to Roon core themselves.