Error in Roon 2.0 documentation - Manual configuration of ARC port

The documentation at https://help.roonlabs.com/portal/en/kb/articles/arc-port-forwarding#Manual_Configuration states that Roon uses 55000 by default. That is not correct. The core appears to assign a port at random and reports it in the Setting | Roon ARC tab. So if you follow the manual instruction without regard to the actual port assigned then you will input 55000 to your port forwarding rule on your router and Roon ARC will not work.

The documentation needs to be amended and references to the default 55000 removed

6 Likes

Exactly. I was wondering about this since I read about ‘default’ port 55000 everywhere, and my Roon core uses a different port without having entered anything manually. With all the trouble people are having with port forwarding, this is quite a bad error in the documentation.

1 Like

I agree. And so simple to fix. Surely correcting the documentation wouldn’t take more than a few minutes for someone from @support?

2 Likes

Hi @John_Warden,

The documentation is correct. The first example in the KB is 12345 but it’s just an example as part of the auto-configuration.

Further down in the article where it talks about manual configuration, it does show the port to be 55000 which is what will be there when you hit the option to manually configure. There is even verbiage in the document to warn you of what might happen if that port is in use:

" Port in use

If you get an error saying the port is in use, that means that the current port is already being used by another program on the same computer as your Roon Core. You’ll need to enter another port in Roon, in the Roon ARC tab of Settings. You can enter any available port in the 10,000 to 65,000 range."

The port used isn’t relevant other than the fact that it must be in the aforementioned range and that any port forwarding configuration reflects the same port as shown in the manual configuration.

Wes

Hi Wes

Thanks for the reply. However, I’m afraid I don’t really follow your argument.

I don’t think this example will have been clocked by many people. Certainly I didn’t notice, and I’m not sure that even if I had, I would have inferred anything from it.

What do you mean? There is no option to manually configure that you can hit. The only thing you can hit is “Reset” which reassigns another port number at random, giving you only a 1 in 55,001 chance of it being 55,000.

But much more importantly, the steps explicitly tell you that “you’ll need to create a new port forwarding rule in your router that uses these 3 pieces of info” and then goes on to specify “55000” without any qualification whatsoever. This is the main thing that is wrong. I would hazard that a significant number of people who failed initially to get this to work (I specifically know of only two!) were misled by a very specific instruction that simply is incorrect as it is currently written.

Another thing that is wrong: “Roon uses port 55000 by default, but you can pick a different port if you’d like.” In what circumstances does Roon use 55000 as a default? I have never seen 55000 in the port box on the Roon ARC tab. I suspect this is referring to how a pre-release version worked.

This whole Manual configuration section should be revised to refer to the actual behaviour of Roon (selecting a port number at random, refreshing with a different port number it if you press Reset) and how you should use that port number in your router’s port forwarding rule, as I suggested in my original post.

Yes, all very interesting, but it doesn’t remedy the explicit instructions given earlier that reference only 55000 without any qualification or explanation.

Thanks Wes. I really think that if you re-read my original post with an open mind, and don’t try to defend the current documentation so hard, you’d see that it could very easily be amended to be much more helpful to Roon users who only encounter port numbers once in a blue moon.

2 Likes

When I hit the manual install, Roon gave me 55002. That’s what I used with no issues.

Click the downward pointing arrow (top right), then enter whatever port number you would like to use for port forwarding.

Once you’ve done that, set up your router to forward traffic to that port.

Yes, just click in the box and input any unused port number you want.

Hi @Jim_F and @DaveN

I know you guys are trying to be helpful, and I can see that you’ve done the manual configuration thing without issue. Just like I did, as it happens.

Perhaps the difference between us is in how we see people who are having difficulty with this process. And that includes sensible people who read the support pages before posting a request for help without doing any research themselves.

The thing is that the support pages are inaccurate and unhelpful. I’d thought I had made that clear, but the response from you and @Wes maybe indicates otherwise.

All I’m trying to do is get this fixed so that the misleading and incorrect “help” pages are edited. But maybe I can’t be bothered any more. I had hoped for a little more support, rather than people just saying “it’s obvious”, but there you go.

1 Like

I thought there really couldn’t be any discussion here… how naïve I am. :wink: The documentation is just plain WRONG, there’s no middle road here. I totally agree with @John_Warden , even though there’s no need to agree with anyone.
Documentation: " **Using a different port. Roon uses port 55000 by default, but you can pick a different port if you’d like.". Where and under which circumstances does Roon use port 55000 “by default” ?
As I said, my ROCK had a completely different port number… so the word “default” is obviously wrong.

2 Likes

This is incorrect for two reasons, which is exactly what John is trying to explain:
There’s only the ‘expand’ right next to the ‘refresh’ button. (Which is probably what you mean by “when you hit the option to manually configure”… ?). So, “by default”, the port number isn’t even visible. So people are just going to assume what is in the documentation, saying the default port # is 55000.

When I clicked that ‘expand’ button for the very first time (I’m glad I didn’t simply trust the documentation), it showed an entirely different port number, NOT 55000. Which proves that there’s no ‘default’ port 55000.

2 Likes

They probably should change the documentation to say, “Click the down arrow to see the port number. If you want to change it, click in the box and type in a different available port number.”

1 Like

This is the problem I ran into when trying to manually set up following the instructions. My knowledge in this area is extremely limited to nil, so I could only try to follow the steps exactly. It was only when I saw another post mentioning having/how to change the port number in Roon ARC settings to match the router settings that I got it to work.

Btw, this is what I saw when looking at the Roon ARC port setting. The way it appears I assumed, per the instructions, that it defaulted to 55000, but it did not. There’s no “drop down” button when viewed on my iPad (I don’t use our PC to control the core). (EDIT: I now see the drop down button the previous poster refered to. I misunderstood and thought it was by the Port Number setting)

image

This attitude that Roon can do no wrong when errors are pointed out (there are other problems pointed out in the KB), that the problem is with the users, is really off putting, to put it mildly.

3 Likes

Exactly! You read that 55000 is the default. You read specific and detailed instructions telling you to use 55000 in the port forwarding rule on your router. You see stuff saying that the port number could be changed manually but think that’s irrelevant to you because you haven’t changed the port number, particularly as you see no reason why you should change it. So the default must be the number to use.

You follow those instructions to use the “default” 55000 to the letter to set up your port forwarding rule on your router because this is unfamiliar territory.

And it just doesn’t work.

I really think it couldn’t be more obvious why the documentation is in error and needs to be changed.

And why expend any more energy defending it rather than simply correcting it?

2 Likes

I agree. If you come up with solid arguments, Roon should take note and simply say: “sure, we should change this/that”. In fact, they don’t even have to admit their mistake for all I care… they should simply change the documentation for this particular item. It’s really not that hard.

But Roon is a collection of individuals just like any other company. Some of them may find it hard to admit a mistake, which is a very human thing really. (This is something I realized last night, after getting really disheartened by Roon’s reply here). So on we go. :slight_smile:

3 Likes