Error Loading database message, reloading app did not help

Hiya, I opened Roon this afternoon and got the Error Loading database message. Deleting the app and reloading it (as suggested here, above or below) did not help. Following your suggestions did! Roon reloaded all my music. I have lost my own custom tag that I applied to ambient/minimalist music. Is it possible to recover the tag and the titles that are tagged by moving a file from Roon_Old to Roon? I also have a Time Machine backup, I could restore the Roon folder from my last back up. The only worry would be restoring little problems that led to the glitch this morning. Any suggestions?
Thanks, John

Hi,

The Roon @support team prefer one topic per customer’s issue… so they are able to track it and focus on each individual problem. hence I split out your topic.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Probably not. Those things reside in your Roon library, which I guess you have recreated/restored.

Time Machine backups can not be used to Restore Roon.

Hi @john_hess,

Time machine backups do not work well with Roon, do you have a Roon backup (one that was created by the Roon application itself)?

Yes? Does this look correct? I can’t remember the last time I did a Roon back up.Screen Shot 2021-01-20 at 5.02.11 PM Thanks for the tip. John

OK, I restored Roon using a Roon backup dated Jan 14, 2021. (Luckily, I have multiple Roon backups, I probably set a weekly backup schedule and forgot about it.) At the end of the process, I relaunched Room and got the error loading message and a big white screen. So I’m renaming the Roon folder in the Library folder, restarting Roon and will attempt to restore from an earlier noon backup to recover my music tags. If that fails, at least I’m getting good at this process.
Thanks for tips/info/advice John

Hello @john_hess,

If the older backup still does not resolve the issue, can you please use these instructions to send me a set of your Roon logs? Thanks!

Hi, thanks for the note. My problem was resolved by restarting Roon and letting rebuild itself followed by restoring from my second most recent backup. I described this in a second post/thread where I asked if it was OK to delete the “bad” backup. I have since deleted the bad backup and performed a new manual backup. I have opened Roon and played music from my library and from Tidal and closed Roon. I think everything is back to normal/good. I have saved the instruction link, just in case.

happy friday!

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.