Ethernet Bridged Connection for Lumin X1


(Christopher Whitten) #1

I am pretty confused as to how or if I can get this to work.
I installed a JCAT LAN Card with two ethernet ports in a HTPC running Roon Core. I want to see if I can bridge the two JCAT LAN Connections and connect an Ethernet cable from one of the JCAT LAN ports directly into the X1 ethernet port?
I have bridged the connection between the two JCAT LAN ports and run an ethernet cable direct into the X1 ethernet port. The Lumin X1 doesn’t show up in Roon.
I searched and have seen the big thread on Computer Audiophile but I can’t seem to get this to work. I also don’t know if it even will work.
Thanks for any help.


(Peter Lie) #2

I believe this configuration has been proven successful before: Bridged Ethernet Any Pro's or all Cons?

In your setup, please leave the SFP (fiber) network port unplugged (so that it does not create a loop in your network).

Firstly, please power cycle the Lumin X1. See if the front panel shows a progress circle or “Network Error”. If no error is shown, then the physical path from router - JCAT - Lumin X1 is good as the X1 can get an IP address. If a “Network Error” is shown, your JCAT is not properly configured or there is some sort of network cable issue.

In Lumin app, please make sure Lumin X1 Roon Ready setting is enabled.

It is important for the HTPC to be configured to allow multicast packets to pass through the JCAT bridge. If you’re running Linux, this may be less easy.

If the bridge is intact and multicast works, you should be able to find Lumin X1 in Roon audio setup under networked Roon Ready devices. You can then enable it and be able to choose it as a playback zone.

If you have changed any network configuration and after that Roon still does not see Lumin X1, please restart the Roon Core.