Exclude DSD from DSP Sample Rate Conversion

Just dusted off my DSD capable DAC. Initially, I found that everything was being converted to PCM, even when Native or DoP was selected in the dac device setup. Turns out that I had sampling rate conversion enabled on the DSP menu, intention to upsample PCM to max sample rate. My assumption that DSD would be excluded. Well, turned off sampling rate conversion and voila, both Native and DoP working beautifully
Is there a way to exclude DSD from sampling rate conversion? - or am I doing things wrong?

The following search did not turn up an answer to this specific issue

https://community.roonlabs.com/search?expanded=true&q=DSD%20sampling%20rate%20conversion

Change to custom sample rate in the drop down Menu choose what rates do what

1 Like

EDIT:
@Simon_Arnold3 beat me…
:+1:

Set it to Custom and then enter your preferences like so …

AAAHHHH!
I am dumb - I was fixated on the “upsample to maximum” option - never occurred to me to check the custom option - thanks!

1 Like