Exclusive mode : roon is not working when disabled

To be clear: exclusive mode IS working (there are several other topics on that matter).
It is when I DISABLE “Exclusive mode”, that roon player cannot play anymore.

Context: ASUS Xonar U7 MkII, on WIndows 10

The exact behavior is the following:

  • music is working properly in exclusive mode
  • I disable exclusive mode in the setting of my device
  • The current song immediately stop as I save the new settings
  • When I click on ‘Play’ to restart it, roon tries to restart playing but fails to and skip to the next song. As the next song fails also, it goes to the next and so on… until I the playlist is empty or I turn back to exclusive mode.

I know exclusive mode is better, but this is a secondary set up (home office), but there the usage is different from an audiophile listening. I also need to be able to switch from other sound sources (video, communications, game, …) and this is ‘complicated’ when roon is running since I need to stop it completely, restart the browser and the other way around when I need to go back to roon.

I tried via ASIO4ALL, … not working either.

Does anyone have a work around? Thanks !

What is the entire setup? Which endpoint do you use?

The endpoint is a WIndows 10 PC, using an ASUS Xonar U7 MkII sound card.
The core is on another WIndows 10 machine, there it works fine (with another sound device).

Here is the entire setup:


Ethernet or USB connection between core and endpoint?

These are 2 separate Windows 10 PCs… so Ethernet (cable)

Could have been USB as well.

Any idea then?

Looked at my setup with a roon core on a NUC and with another PC as an endpoint connected via ethernet. I don’t even see the option exclusive mode in the core or the endpoint settings. Had notebook as roon bridge for a test some time ago and the settings do not show exclusive mode. I don’t know how you got there.

Can anyone else help on this issue?

Thank you!

Ive got the exactly same problem

Roon core on windows
Any device should be on exclusive, It seems that no matter that u slected on windows options, roon needs to be the only one which control the device to make it work.

Any ideas?

You can try and disable “Event Mode”. Also if your system output is multichannel, try to use the appropriate “Channel Layout” and see if enabling “Send stereo/mono content as x.x” changes anything.

Tv and AVR were configured on atmos in windows.
Ill try ur suggestion and let here the result.

Thanks mate.