Feedback for Carplay and Android Auto in ARC

Hey All,

We’re working on a few improvements across Carplay and Android Auto. I’m aware of a few bugs which are impacting performance, notably broken image loading. However aside from bugs, how is Carplay/AA working for you?

If you’re able to provide any videos or pictures of the Carplay/AA interface that help illustrate any qualms that would help.

Also, if you want to speak directly and actually hop in the car, I’d love to look over your shoulder. Feel free to shoot me a DM and we can arrange a call.

Thanks everyone.
-Michael

1 Like

When ARC is offline therefore with the tracks saved on the phone it sometimes goes into cylon mode with with a cursor just tracking backwards and forwards instead of a progress bar and track time.
If I can get it to do it whilst stationary I’ll do a video.

1 Like

I’m forced to use my phone in a mount which is fine now that Voice Typing is fixed. Lately Google assistant seems to want to play YouTube Music when I use AA. Also the interface takes so long to load anything that I’m more likely to crash waiting for the menu to load in Android Auto than just using voice typing and starting an album with my phone in a mount.

Moreover the bug I reported many months ago here: Intermittent Navigation Prompts Play Over Music on Roon ARC - Android Auto (ref#E04H8L) - #11 by mackid1993
still hasn’t been fixed. Intermittently the music won’t duck over the navigation prompts and I have to force stop ARC in order to hear Waze.

Improvements:

  • ever since the implementation of Android Auto I have had bugs where, randomly, the playback time would stay at 0 and the progress bar would flash as if it were loading (You had to pause and resume the song on AA for it to display correctly. Or wait for the next song). Maybe it’s the same bug reported by @ged_hickman1
  • Another bug, here too randomly, a cover was shown that was not consistent with that of the album being played but one of an album listened to previously. Here too you solved the problem by pausing and resuming listening from AA

Now they seem resolved (or it happens less frequently). I will give an update here should these issues reoccur

Bugs:
as reported by other users, from some builds I have the black screen problem in ARC. This mostly happens when I’m connected to AA and turn off my machine. When I reconnect and AA starts up, I can see the ARC widget on the machine’s screen, but it’s black with no way to do anything. Sometimes the music plays anyway, sometimes it doesn’t. To get ARC back on AA I have to force stop the app from the smartphone and reopen it

Today I tried to use ARC online in AA but was presumably in a weak signal area so just got the purple’ish background loading screen. Pulled over and took ARC offline without switching off the head unit or disconnecting the phone from AA. Went back to ARC now just a black screen.

Thank you, that’s helpful. What time did this happen?

About 11:20 am my time.
Now I’m aware you want scenarios I’ll try and remember to note them rather than just getting on and rebooting everything :sweat_smile:

My biggest issue is that when I summon siri on Carplay, it does not resume audio playback after and I have to press play manually. I do not see this behavior on Tidal.

Unfortunately I have to change this previous statement.
Both bugs have recurred these days with the latest EA builds (ARC 257 and Roon 1391)

Yesterday evening ARC ept skipping tracks in a downloaded playlist saying corrupt media.
I was driving so no idea what tracks it was complaining about, I just had to keep skipping forward when it went quiet and stopped.
One unrelated thing, I’m sure there used to be a dedicated ARC volume control slider?

So far I’ve ran into an issue twice with Android Auto where the ARC app on my phone works, but Android Auto will literally just have a loading spinner that never goes away. This also breaks steering wheel controls. Force stopping ARC fixes it.

1 Like

AA is not really usable in B260, moreover ARC seems to be using less battery now-- still to early to tell on that though.

My current use of Arc through Android Auto on B260 has been good.

Issues experienced are:

• Now playing screen doesn’t always show on occasions

• On occasion the now playing screen is blank with a spinning purple coloured circle

• Arc touchscreen control doesn’t work on occasions

Music does play and control via my phone is still possible.

This is in a Vauxhall Vivaro van.

I am lead to believe the AA in this van is the latest version.

Experience in our family car is ok, but I don’t spend much time using my phone/music as the wife insists she listens via Spotify on her phone.

Added info: I’m only using Roon and Roon Arc with local media. Albums are also downloaded in the Arc app, but not in offline mode.

Will try offline mode tomorrow to see if the above issues clear up.

Update. Our family car is like this, same as my works van.




This was happening on the latest production build also and I have an open post about it with @support

When it works, the B260 is faster in loading pages as described in the release notes. The biggest problem now is an “indirect” problem and it is what now afflicts with different Arc builds: the black screen. With Android Auto it often happens when you disconnect and, later,you reconnect. the only solution is to force the arc interruption and restart it

Mine stopped doing that after I rebooted the phone.

1 Like

Cheers Ged, I’ll give that a try :+1:

1 Like

Force stopping the app fixes that issue.

I had to do a reboot a forced arc restart didn’t do anything.

Force closing didn’t resolve for me, tried a good number of times.

A reboot has though.

1 Like