Feedback UID 03ff2d6460cbf929 - Another instance of RPi endpoint not showing up in Roon

I am trying to get an RPi 3B with the latest RoPieee recognized in Roon. The Roon Core is a Mac mini on WLAN The firewall is off. The RPi is on WLAN I can ping it and, obviously, access its web interface. The green LED on the Pi is flashing slowly. The audio HAT is an Allo DigiOne. I unticked the USB toggle on the General page of the web UI. And I did reboot the Pi.

Does the info contained in the feedback provide any clues to what might be wrong? Grateful for any pointers.


Hi Ralf,

Everything on the Pi looks ok. RoonBridge is running, HAT has been recognized.
So this might be a network issue.

Is there any chance you can test this with UTP cables?

Hi Harry,

Thank you for looking into this, I really do appreciate this. Yes, it’s the WLAN. Ethernet works. WLAN cannot be active on the Ropieee at the same time. The Highlander Pattern applies here, I reckon.

To confirm, I reversed to WLAN-only. Doesn’t work. Went back to LAN-only. It is working. Nice. Unfortunately I really need this to work on the WLAN.

Any chance a USB WiFi dongle would work better than the on-board WiFi? Can you suggest a brand/model which has a good chance of success?

RoPieee supports a WiFi dongle (see the website) from Allo.

But it really should work with onboard WiFi as well. Is there a firewall involved?

The macOS firewall on the Roon Core Mac mini has been switched off since when I first installed Roon.

My router (Ubiquiti USG) has default firewall rules for LAN traffic. These cannot be edited. They are set to permissive anyway, so I doubt they are causing this. Plus, I have another Mac mini in the network which is working just fine as a Roon Bridge. Ditto for a MacBook running full Roon; both via WLAN.

I am going to purchase a 3B+ (Plus) model. It’s been months since I bought the last one. Maybe it’ll work with RoPieee over WLAN, maybe not. If not, I have other applications for it, no problem. I’ll report success/failure here.

Problem solved

By default my router blocks multicast/broadcast traffic to WLAN devices. I added an exception to allow the Roon Core computer to send multicast/broadcast data. That was it.

Interestingly, with RoPieee on the new 3B+ the WLAN path worked even without the exception, i.e.
3B: LAN OK, WLAN fail