Finally, a viable Raspberry Pi alternative!

I actually got it from Printables or Thingiverse, I can’t remember because I looked at so many. I tried to find the link for you but couldn’t. I might try a couple of others that looked interesting.

Also, a question about the eMMC. In my setup the only job the Le Potato going to have is to stream Roon. It works perfectly fine right now. Am I wrong in assuming there is no reason for me to go down that rabbit hole as well? Thank you.

For your use case, eMMC offers no benefits that I’m aware of. I measured a sequential write rate of about 5.5 MB/s with my Sandisk microSD card compared to 72+ MB/s writes with eMMC. Read rates on eMMC are above 165 MB/s compared to 22.5 MB/s from microSD. However, when you’re running Roon Bridge, there’s virtually no local I/O to storage internal to the streamer. All it’s doing is reading music from the network and copying it to the USB-attached DAC. Also, the Armbian distro stores system logs to a little ramdisk to minimize wear and tear on your flash storage.

I’m a Unix/Linux nerd, so having fast storage is appealing to me. I expect that boot time is faster with eMMC, but the device boots in seconds either way, so the difference will not be significant for most folks. Good question.

Are you able to get the temps by just typing in cpu-temp? I know nothing about Linux. I can paste the entire script and get these results, but not just cpu-temp.Thank you so kindly for indulging someone who doesn’t enough to be considered a newbie!!

1 Like

Oh, just save that to a file called cpu-temp and make it executable with something like this:

$ chmod +x cpu-temp

Then, more the file to a folder that’s in your shell’s PATH. For example:

$ sudo mv cpu-temp /use/local/bin/

Edit: I left out a step…how to save that script to a file. Probably the easiest way is to just download it from my little repo:

$ curl -o cpu-temp -L

Thank you so much!! Got it, but after a bit of Googling I had to change the above quoted text to '$ sudo mv cpu-temp /usr/local/bin/` to moveit to the other directory.

1 Like

Fixed. Thanks. :slight_smile:

Will this work on a odroid N2 Coreelec device?

I don’t know, but if you have one, please give it a try and share your findings. :slight_smile:

1 Like

im doing just that …will let you know

1 Like

Did you use the CLI or Desktop package of Armbian?

The CLI package. After setup, there’s no need to have a display or keyboard attached to the SBC.

Just to let everyone know I installed the Desktop version of Armbian on the odroid n2 after taking out the emmc flash module…flicked the spl switch to the right so bypassing petiboot and once I was in the desktop I downloaded roon bridge as per the guide…I had a roon endpoint show up straight away after connecting my smsl m500…you don’t even have to log in to the desktop on booting up Linux…the roon bridge works fine…

1 Like

That’s great news. Thanks for taking the time to give this a try and sharing your results!

The desktop version should not be required. In fact, the fewer packages you install (or the more you can uninstall), the better these little devices will perform. In theory, at least, you want them to run lean and mean. But, this was a great test.

Thanks David I will redo this with the CLI version tomorrow and report back…

1 Like

I’m curious if the potato or the odroid show the same hostage lossage that I saw on the Renegade. /var/log/messages was full of log messages from this service before I shut it off.

I don’t know what that is, but I don’t see any occurrences of hostage anywhere in the logs:

$ sudo grep -ri hostage /var/log
/var/log/auth.log:May 10 18:36:36 lepotato sudo:  dsnyder : TTY=pts/0 ; PWD=/var/log ; USER=root ; COMMAND=/usr/bin/grep -ri hostage /var/log

Well, none besides the one that the system added when I ran this command. :slight_smile:

Great thread. Thanks for posting.

Got a 3+ running roopiie here atm, but definitely look at one of these for my next build

1 Like

Just ordered the kit. Huge THANK YOU for taking the time to post this!

1 Like

Great. PM me if you have questions during the build. Share a photo of your final setup once you have it together.

I have another board arriving next week. I’m planning to livestream the assembly to YouTube, along with some Q&A. Should be fun.

Just reporting back that the CLI installation went smooth and running my SMSL m500 and Odroid N2 with no issues!