Fire Tablets and early access, can’t install

So almost all is well, now that I figured out how to get almost all my remotes into early access (hasn’t figured it out until today). My new Fire HD10 is not on early access.

On the Fire tablet I went to the earlyaccess help page from the silk browser, downloaded the Android Roon Remote APK, went to the files app, ran it and it said “Program not installed”. I’m assuming I don’t have access to the Fire tablet root. Does anyone know how to do this? Note that the only way to easily get Roon production onto the tablet apparently was when someone added it to the Fire App Store. I’m hoping I don’t have to wait for some one to do that in order to get early access on my HD10, cause it’s great.


Did you enable “installation from unknown sources”?
If not, here’s a guide:
Go to the main Home page on your homescreen and tap the Settings icon.
Select the Security & Privacy category (older models might say Security), and turn on the Apps from Unknown Sources toggle.
If tapping Apps from Unknown Sources brings up a list of apps, don’t do anything. You may receive a popup when installing APKs, where you’ll tap the Allow button when prompted.

I tried to do the same today and it failed to install as well. Then I uninstalled the existing version of Roon Remote and tried to install the apk again and it succeeded. Not sure exactly why but hopefully that works for you as well.