Firewall changes? Linux

Roon Core Machine

Linux Ubuntu 20.04.2 LTS
Roon 1.8 build 882

Networking Gear & Setup Details

NetGear Orbi

Connected Audio Devices

Number of Tracks in Library


Description of Issue

Something must have changed with ports because the Roon app on Windows and Android won’t open without disabling the firewall on my Linux computer.

What port ranges should be open? thank you

Something must have changed with the ports recently,

You have posted on the very thread where the solution has been given. Just adjust your firewall rules accordingly.

[shakes head]

For everyone that may see this thread, here’s what works for me as of this date.
[ 2] 9003/udp ALLOW IN # roon
[ 3] 9330:9339/tcp ALLOW IN # roon
[ 4] 8008:8009/tcp ALLOW IN # roon
[ 5] 30000:30010/tcp ALLOW IN # roon
[ 7] 1194/udp ALLOW IN # roon

1 Like

This is interesting to me. I have the Roon core (and HQ Player) on Ubuntu Server (I am a novice though really, and still learning how to use via the terminal) and I wanted to enable the firewall allowing UDP port 9003 and TCP ports 9100-9200 recommended in this thread however I couldnt get it to work. I just tried, on the off change, the above and its working now.

Yes, those were the old port settings, but since build 880, new settings are in place.

Thanks, I have removed now.

Here’s how to enter a rule, commented for Roon, on a local subnet (one line).
sudo ufw allow from to any port 30000:30010 proto tcp comment roon
You can also use the package gufw which is graphical.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.