Firewall settings


(Frederik Gilliaert) #1

Hello,
I’m using roon server on a ubuntu server system. I’ve configured the firewall, but I can’t find any of my audio outputs (I especially need to connect to my Naim Nova system).
This is my current firewall config. I’m sure I’m missing some ports that I need to passthrough, but I can’t seem to find the necessary ports anywhere…

9100:9200/tcp
9003/udp
52667/tcp
52709/tcp
63098:63100/tcp
49863/tcp

I hope you can help me out…

Grts!


(simon arnold) #2

What’s your network config, what are using in-between the core and the Nova and how are your remotes connecting . It’s likely s network discovery issue of some kind and not the actual ports that need opening.


(Frederik Gilliaert) #3

Hi, thanks for your response. The ubuntu system is actually a virtual machine running on esxi with the network routing handled by a pfsense virtual machine. My remotes are connected to the pfsense virtual machine that allows traffic to the ubuntu vm without restrictions (all internal network traffic).

I forgot to mention this, but with the firewall disabled in ubuntu all works as it should. This makes me conclude that it is a porting issue.

grts!


(Martin Webster) #4

Those ports should be fine. I tend to do a sudo ufw disable when installing a new Roon release to ensure all devices are discovered. As soon as they’re visible in Roon Settings > Audio I issue a sudo ufw enable.

I simply forward the following:

  • UDP port 9003
  • TCP ports 9100-9200

(Frederik Gilliaert) #5

So certain ports are only necessary for discovery and you can close them afterwards…

I tested it and it worked initially, but upon rebooting Roon my outputs were once again lost…