Fix for android connection problems?

Will Roon finally fix the android core connection problem or will we continued to be ignored? Those of us who were stupid enough to pay $700 for this crap are Roon’s marketing nightmare. I have plenty of audiophile friends and I always tell them to avoid Roon due to the constant connection problems and the lack of customer support.

5 Likes

It’s not Roons fault that some phone vendors break standard network multicast implementation and the Android network stack is full of issues. These problems affect many applications that rely on multicast for discovery not just Roon. I only had issues with Samsung phones, had two other makes since and they run perfectly fine.

Since Samsung phones are among the most popular phones on earth, it shouldn’t be a problem for roon to fix this issue. It’s literally the only app I have that has consistently failed.

1 Like

All my Android devices work fine Samsung, OnePlus 5 and 7, hauwei and even a crappy pioneer DAP that has the weakest wireless modem in the known universe.

Good for you!

Do you have Netgear network hardware? They don’t play well at all with Android and Roon.

I have a Netgear switch, but it’s not connected to my ROCK. That is being fed directly from the Asus.

Well you seemed to be including all users in your generalisations so I thought a contrary view would be appreciated. Apparently not…

I never said ‘all users’, did I?

I’m referring to the many android users who have this same problem.

2 Likes

OK, I feel the need to comment here. I have used 3 or 4 different Android devices with Roon and currently have no issues whatsoever. Yes, the loss of connection to the core when the Android device locks or goes to sleep was annoying, but as I explained to another fairly irritated member of the community just a couple of days ago, this isn’t a Roon issue. It’s an issue with the Android kernel’s default behaviours. If you exempt the Roon App from Android’s memory and battery optimisation controls, losing the core connection on device sleep or lock is no longer an issue.

I also see people having issues which are clearly network related. Roon is fairly demanding of network resources, especially if you’re streaming to multiple endpoints. It has to feed the same stream separately to each endpoint which requires quite a bit of bandwidth. The higher Res the stream, the greater the bandwidth requirements. Most home users have little or no concept of network setup. They just plug stuff together and assume it will work just fine. And with the likes of Spotify for instance, streaming at only 320kbps, it usually does.

Roon just shows up the cracks in a poor setup…

The best advice I can give anyone is to try wherever possible to avoid running it over wifi. Unless you’re using enterprise WiFi gear or a seriously good consumer WiFi setup with a wired backhaul, you’re likely to encounter problems somewhere along the line.

It’s not Roon’s fault if your infrastructure can’t cope with its service.

My Roon core runs on a NAS, which isn’t really recommended, however my enterprise grade NAS is more than up to the job. The Roon end of my storage setup (core, database and music library) runs on RAID0 SSD arrays (blindingly fast read and write speeds) and the NAS has a 20Gbit fibre connection to an enterprise switch, which in turn feeds the endpoints individually over Gbit Cat6 wired connections. My WiFi network uses enterprise grade APs with wired backhaul, but other than a couple of Sonos Play 1s and the usual phones, tablets etc. there’s nothing on it. And BTW, my entire network setup cost less than a mid range audiophile amplifier…

Why do people buy really high-end hi-fi systems costing tens of thousands and stream to them over the cheapest, lowest performance network setups costing hundreds and complain that it’s the streaming service that’s at fault?

8 Likes

Non sequitur.

I had those exact settings on my last phone and have them on my current phone.

My infrastructure is definitely not the problem. Making excuses on roon’s behalf without context is only wasting my time and yours. I’m running cat 7 from my Asus to my core and cat 7 from my core to my Bridge. It takes my new phone (S21 Ultra) forever to connect to the core even though it has the same exact settings as my previous phone (S20 Ultra).

Many Android users are experiencing the same problem. Just because you aren’t doesn’t mean the problem does not exist.

The last phone worked fine after a while. This new phone is running the same settings as the last one, but fails to connect frequently. This is extremely frustrating when I simply want to adjust volume or change a track. I’m very happy to hear that you’re not experiencing the same problem that I and thousands of other android users are experiencing. Assuming that I know nothing about networks, however, is insulting and unhelpful.

Why hasn’t anyone from Roon responded?

Specs from original post:

Core Machine (Operating system/System info/Roon build number)

Roon Rock, NUC i7 w/16GB RAM, version 1.7 (build 710)

Remote: Samsung S21 Ultra w/16GB RAM (app version 1.7, build 610)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus AC2600, cat 7 ethernet, 600 mbps

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.) *

Mytek Brooklyn Bridge

Description Of Issue

My remote device is having difficulty consistently connecting to my ROCK. I often get stuck for minutes with at Waiting To Connect message and I am not able to Configure Roon OS in the Setup menu.

If your set up was working with the S20, why don’t you just use that as a remote?

Where have you got your numbers from?

O, at illud facit!

I didn’t assume you know nothing about networks. My comments about networks were meant in general - not directed specifically at you.

However, while we’re on the subject, just stating Cat7 means nothing. Cat7 is an ethernet standard/cable type which incidentally is not is an IEEE compliant standard and is not approved by TIA/EIA. It uses a GG45/ARJ45 connector rather than the standard 8P/8C connector. It was the first ethernet cable type to offer 10Gb/s over up to 100 metres of copper cable. It’s no better than Cat5e in your setup unless your router and Mytek are more than 50 metres apart, but of course you knew that already? It’s also effectively a redundant standard, roughly equivalent to the (newer) Cat6A and now superseded by Cat8 - I guess you knew that too?

The RT-AC2600’s interfaces are Gbit - is 600 Mbps, your incoming internet connection speed? You say you’re running Cat7 from router to core and Cat7 from core to Bridge. Does your core have 2 NICs, or are your core and Bridge both connected to the RT-AC2600’s switch ports? Where in your network is your DHCP server? Is it your ISP’s modem/router or the Asus? Is your Bridge on a dynamic IPv4 address or a fixed IPv4 address, or does it have a reserved IPv4 address leased over DHCP from the router?

My note 20 Ultra and Tab S7+ work just fine with Roon, as does my Lenovo Tab P10. Can’t see how this is an issue with Roon.

4 Likes

+1 to what Graeme said. I’ve been using Android for Roon Remote for years, connected via wifi, for years now with no issues other than it loses connection when the phone locks and has to reconnect when I next try to use it, which takes a second or two. I should mention I’ve used Eero wifi bridges, and also Netgear Orbi with several satellite remote units. My roon core and wifi base are connected to a gigabit ethernet switch (a Netgear managed switch) same as the router to connect to internet.

Do I understand you’re using Roon Core on an Android device? I didn’t think that was a possible configuration.

@Kursten_Hogard I feel like if you’re having so much trouble there might be something wrong with your wifi connectivity. I suggest you install a network tools app like Hurricane Electric network tools and check ping and packet loss to the IP address of your roon core. If you change the ping payload size to send large ping packets (1500 bytes or more) you can also get a sense of how much bandwidth you have from your phone to the Roon Core. This might help you identify whatever’s wrong so you can fix it.

@Kursten_Hogard Can I just check that you’ve tried the 255.255.255.255 fix.

Are your S20 and S21 running the same version of Android? There does seem to be an issue with Android 11, at least with certain Samsung devices.

Have you used static IP addresses for everything in the chain? (Sorry, I think @Graeme_Finlayson asked that one already, but I’ll leave it in).

I’m not seeing the option to enter the ip address, unfortunately. I’m not sure what version of android was on the s20, but it was probably the same as the s21.

1 Like

The problem is that this problem is not confined to Android. It affects my IPad as well as my LGV30+. It is also not a consistent problem. The ability to make a connection comes and goes, sometimes for both devices simultaneously, sometimes for one but not the other, when they are in the same room next to each other connected to the same network. Sometimes typing in the IP address (for the umpteenth time) works immediately. Sometimes not. Meanwhile good old but now un-used (because I have lifetime Roon subscription + non Sonos end points) Sonos S1/2 is ultra reliable on the same network. I know there are excuses but I just think it can’t be that hard…

You first need to click on ´Select different core´
It will not find another core, but you will see the Help link.
Click on that and you will have the option to enter the ip-address 255.255.255.255
Dirk

Sorry @Graeme_Finlayson this really is not the case at all. I have Roon setup with no battery optimisations and always have on every device, current one a Google Pixel. It still does this behaviour. I do think this is more to do with memory management and if it runs low it gets closed. It’s only Roon that does this, I can have other apps running this does not happen to, such as BubbleUPnP or my Naim App. I see this behaviour more so on my Android DAP as it has way less ram than my Pixel 4 with just 2GB.

As well as Battery Optimisation, there’s also the facility to prevent apps from sleeping, at least there is on Samsung devices.

1 Like