For people struggling with Roon 2.0.25 on Linux with Bottles/Wine

This worked for me until a few days ago. Now I get an error of ‘no suitable tmpPixelFormat available’.
Anyone know what might have happened or how to fix? Creating a new bottle with the same setup resulted in the same issue

Hi All,

I get Roon running on PopOs 22.04 through Bottles. It’s work great even with HqPlayer. However, when I try to sue my phone’s Roon or Arc. It’s say’s it can’t find a RoonServer. I am curious any experience this issues? and how to solve it? Maybe there need some network set up in Bottles?

I get the Roon Server Status:Running showed up.

Roon Server should be running natively on Linux; use Wine Bottles only for control.

Hi,

Thanks. Another issues occured this morning is that I can’t login into my room account after set up the server. I get into the login setup and login my details on webpage. However, it won’t redirect to my Roon Bottles. Any fix?

SOLVED: Choosing a different Server because I reinstall a new Roon-Server

No, not so far. You may have to use a supported Roon client installation (a phone, tablet or supported desktop client installation) to log into Roon and “unlock” the sever. After you’ve done that, you should be able to use it with the bottled client too.

1 Like

Hello everyone.

I would like to install ROON on linux FEDORA 40 under Weyland and I will follow your instructions carefully.

I have installed Bottles Flatpak and I see in Bottles settings that you indicate here:

Runner: wine-ge-Proton8-22

Should I install Proton in addition to Bottles?

Thanks for your help :slight_smile:

Jean-Louis.

Salut Jean-Louis,
no, it’s under Settings - Runners at the bottom.

OK. Merci :). !

For me app worked once and after I tried to play song it crashed and now it opens shows albums page and crashes.

For the Linux users who don’t mind loosing functionality for improved ease of use; I started a project for a native Linux GUI for Roon. It is available as a Flatpak.