For people struggling with Roon 2.0.25 on Linux with Bottles/Wine

Hi all,

I was struggling with Roon 2.0.25 on Linux.

Up until now (build 1311), Roon Desktop Client has been working beautifully through Bottles/Wine, but upgrading the old version doesn’t work (getting “There was an error checking for an update”), so I first tried a fresh install in the same Bottle.

But no luck.

So in case others are struggling:
Create a new bottle, install the dependency dotnetcoredesktop6, install a fresh install of Roon.

My working settings are using:
Runner: Lutris-GE-Proton8-22
DXVK: dxvk-2.3
VKD3D: vkd3d-proton-2.10

1 Like

What OS, DE, kernel, and window manager are you using?

Hi Martin,

I’m running Nobara Linux with KDE (Wayland) and kernel 6.5.9.

1 Like

Yeah… I still think we should build a Flatpak.

I’ve done some tinkering in the past, but the lack of time has stalled it.
But with a Flatpak we’re in better control of which Wine version we’re using etc.


I’m having issues with Roon on Wine at the moment. It started a few weeks ago on Ubuntu 23.04 and has continued with 23.10. In a nutshell, Roon crashes immediately a zone is selected, and once selected, the app closes immediately.

I’m running GNOME 45, Wayland, and Linux 6.5.0-10-generic.

@spockfish, I agree that a Flatpak would be good. I’m currently using WayDroid and this works reasonably well. The only issues are:

  • Screen scaling
  • Colour balance
  • Trackpad scrolling only works with a press and hold

@Jan_Terje_Hansen, I’ll try your settings in Bottles.

Mixed results playing with the runners. Whilst I managed to get Roon running without crashing when selecting an audio zone, it would close when switching desktops.

I couldn’t find and install Lutris-GE-Proton8-22.

My Roon on Wine also broke after an update of wine-staging. So tried Roon using Botlles and got it working on Linux Mint 21.2 Cinnamon with Kernel 5.15.0-88-generic.

Bottles - open hamburger menu > Preferences > Integrations > click List Stream Apps in Programs List

Runner: wine-ge-Proton8-22
DXVK: dxvk-2.1
VKD3D: vkd3d-proton-2.10
Dependency dotnetcoredesktop6 installed

A Flatpack would be great! Sorry, my coding abilities are very limited so no help to such a project.

1 Like

My working settings are using:
Runner: Lutris-GE-Proton8-22
DXVK: dxvk-2.3
VKD3D: vkd3d-proton-2.10

Works fine with these settings, using the flatpak bottles. I overlooked that in gnome software (fedora 39) there are two versions and installed the wrong one (rpm), that did not work.

These settings worked fine for me as well using the flatpak bottles.

It’d be really helpful if you provided details of your OS, so we may establish the configs that work. Thanks.

I’m running Pop!_OS 22.04, with GNOME 42.9, X11, Kernel: 6.5.6

1 Like

I encountered many issues (hard locks, mouse pointer, …) with wayland in general on current Ubuntu 22.04 LTS; switching to x11 resolved them. See also:

Also using x11 and not wayland.

PS: I was still using the old runner (Wine-GE-Proton8-17) without issue but now switched to the latest 8.22 out of convenience (for me) too.

System Information
OS:              GNOME 45 Flatpak runtime
Arch:            x86_64
Kernel:          6.2.0-36-generic
Desktop:         ubuntu:GNOME
Display Server:  x11

OpenGL Version:  4.6 (Compatibility Profile) Mesa 23.2.1 (git-49a47f187e)
OpenGL Core:     4.6 (Core Profile) Mesa 23.2.1 (git-49a47f187e)
OpenGL ES:       OpenGL ES 3.2 Mesa 23.2.1 (git-49a47f187e)
Vulkan Version:  1.3.261

Wayland on 22.04 is a completely different beast to Wayland on 23.10. The latest Ubuntu release is probably the most stable and polished OS I’ve used in a long time.

I’ll not sacrifice the benefits of Wayland to get Roon running. IMO, the APK is more likely to lead to a better Linux experience, if a couple of niggles can be resolved.

Someone posted a workaround on the Roon-On-Wine github if you happen to use the Spockfish script. It is currently working for me with wine-staging 8.20 on Ubuntu 23.10 using Wayland. You need to add a DLL override to the script.

1 Like

I’ll give this a try this evening. Thanks for posting.

1 Like

And you think that switching the display server as a test is changing that? Or is x11 no longer included anyway, switchable from the login screen (now requiring additional packages being installed that may or may not influence system stability)?

I tried an X11 session, and it wasn’t any better, but I wouldn’t switch from Wayland now as it is a far superor experience, and uses less resources.

I’ll try the workaround @MagicSmoke posted later this evening, and report back.

Thanks, @MagicSmoke, this works for me, too.

However, I am seeing higher CPU (and core temperatures) with the latest release of Roon.

1 Like

This worked for me (Mint 21.2, Liquorix kernel)
Thanks so much for this, I had spent hours trying to make it work using wine manually (before I realized how great bottles is) and was about ready to give up or downgrade to 1.8 when I found this and had it working in minutes.

1 Like

Fedora 39, Gnome 45 w/ wayland.
Bottles com.usebottles.bottles 51.9 stable system # installed from flathub, not the rpm (!)

Just noticed that download of booklets also works.