Forcing tracks to play in a particular order

I am in the process of ripping all of my LPs, so that I can play them back from disk, using Roon’s convolution capability.

I am ripping the LPs a side at a time - can anyone tell me how I can ensure, for example, that when
I listen to “The Wall” … it will be played back in the correct order - ie. side 1 followed by side 2 … etc.?


You could use a metadata editor to add tags to your files but easier would be to just name the files in accordance with Roon’s recommendations.

The link pertains to multi disc sets but the principles are the same.
Ie. Name the files, for example:
01 - The Wall Side One
02 - The Wall Side Two
03 - The Wall Side Three
04 - The Wall Side Four

Thank you, Jeff.

That makes sense … but I have a question: how do I change the text I entered against each track when I pulled them into Roon (after ripping them and then creating FLAC files, using Audacity)?


1 Like

I’m not sure what you mean.
Are you saying the files are now in Roon but were named in a less than ideal way?
If so, Roon doesn’t/can’t make changes to the original files but you might be able to edit the album within Roon so it plays correctly.

Edit - I meant edit the tracks.

Click the 3 dots beside the track name

This will bring up a menu. Click Edit, then Edit Track

If you want to update the tags in the files themselves you could use a program like “mp3tag” to do the tracks. (yes, it works with Flac files, too)

1 Like

My thought too.
By having the files named and tagged accurately if for whatever reason you want to play them outside of Roon those edits are preserved.
As I mentioned above edits made in Roon are saved to Roon’s database not the files themselves.

I had a horrifying similar experience when I left iTunes.
I’d spent years editing my library to be “just exactly perfect” only to discover those edits were contained in the iTunes database, not my files, putting me back at square one.

Edit - although for your specific use here @Andrew_Redwood you’re likely going to have to do some editing within Roon anyway as Roon isn’t going to identify your albums as your files are entire sides of LPs rather than individual tracks.
If it was me I’d being adding tags and editing in Roon.

Thanks, Jeff. (@Placebophile)

I found the Edit screen and changed the names of the 4 sides of a Brandt Bauer Frick LP that I had ripped - see attached pic.

I then set Side 1 playing and waited - hoping that it would roll on to Side 2.

Unfortunately, it didn’t - it selected a completely different track. :roll_eyes:


Check the track numbers on the edit screen and be sure they align with the side names.
It’s also possible you have Roon set to shuffle (check the queue)

Thanks, Jeff (@Placebophile).

According to the attached pic … I don’t think I have selected ‘Shuffle’?

But, sorry, I don’t know how to make track numbers appear. :frowning_face:


No Shuffle

Without being able to view your files etc I’m just guessing here as there are different variables that could be causing this but we’ll figure it out.

I haven’t used Audacity in ages but I think what’s happening here is that your files don’t have track numbers assigned to them and/or that the file name isn’t prefaced with a number as I suggested.

If you edit a track in Roon, as above, be sure there’s a track number assigned to the tracks.
Once that’s done I think you’ll see the tracks ordered accordingly when looking at the album.

But I’d highly recommend getting a meta tag editing program.
I use a paid one but this free one is popular.

After you rip your LP you open the files in the program and edit them adding track numbers and other relevant info.
Once this is done Roon should play them in order.

That said, it’s possible your issue is because Roon can’t identify the albums as your rips have less tracks than, say, a CD rip would.
I’m not sure about this but my hunch is that your issue is because the tracks aren’t named or tagged in a way Roon recognizes.
Using a tag editor should resolve that and as mentioned would/should enable other software to recognize your files in the future if need be.

And make sure “Show Track Numbers” is enabled in Settings. This will help us see what might be happening. I suspect right now this field is blank when looking at your album in Roon

Thanks Jeff. :+1:

I have ‘Show Track numbers’ as ‘Yes’ … but I do not see the 1-1 / 1-2 / 1-3 … that your screen shows. :frowning_with_open_mouth:

1 Like

OK we’re getting closer.

I looked at my files

The track numbers displayed in Roon correlate to the numerical prefixes in my file names.
Ie. 01-01 for In The Flesh.
My files also have track number metadata tags.
You’ll want to check your files also have these.
I think just having numbers in the file names will do the trick but both would be best.

Let me know if that helps.
We might have to check your Roon import settings as well but one thing at a time.

I’m slightly concerned I’m missing something obvious here - as I’m want to do.
Hopefully I’m not having you run in unnecessary circles.

This Settings menu lets you configure which actions are available in the Play menu, and your screenshot only shows that you haven’t enabled the shuffle option there.

However, this doesn’t say for sure if you accidentally enabled shuffle on the play queue, which is separate. You can see this by clicking the queue button on the play bar at the bottom of the Roon window. There will be a repeat/shuffle button once you see the play queue.

It’s probably not the cause of your problem, but just for completeness.
@Placebophile has you covered otherwise

Sorry, @Suedkiez … what do you mean by"clicking the queue button on the play bar at the bottom of the Roon window."?

Do you mean this bar?

Which brings you to the play queue where you find the Toggle Shuffle button:

Thanks, @Suedkiez.

I clicked on the icon you showed me - and, yes, that took me to the “Queue” screen. So then I clicked on the “Toggle Shuffle” icon which you pointed out … but this didn’t stop the next track played being some random track - not the next one down in the track list. :cry:

You do have to make sure that Shuffle is not enabled, not just blindly click the button. If it was not enabled so far, you may have enabled it now. The button changes the color when enabled.

But like I said, it was not very likely that it was the cause. I just mentioned it because you were confused about where the shuffle toggle is located and looked in the wrong place.

Do you have streaming services? I would test the whole thing with a known-good album from a streaming service, not your rips which may have whatever tagging issues. By confirming if the issue occurs with streaming service albums, you can rule out some things

1 Like

Sure, @Suedkiez … when the first “next track” happened, after I had clicked on that button, and I found it was still random - I clicked it a second time and looked at what happened when the track that was playing, ended.

No, sorry, I have not signed up with a streaming service.

Again - just another random track.