Gapless playback in Roon


My setup is the following:

Roon core → Pro-ject ultra streamer → Chord qutest → Naim NAC 202. I use tidal and Qobuz as streaming services.

As an option to the pro-ject streamer, i have a chromecast audio connected with an optic cable to the chord qutest.

Either way, I am not able to get gapless playback in Roon.

Anything I can do to change that?

Thanks and best regards


Hi @Walter_Del_Castillo,

Do i understand it correctly, that you select as Roon endpoint your Chromecast? If that’s the case, as far as i know Chromecast isn’t gapeless.

Kind regards,


Hi Maarten,

Thanks! That explains the chromecast part.

However, my other Roon ready streamer from pro-jet is not doing gapless either. That issue remains. Don’t know if it is the same case as chromecast.

It would be helpful to have a list of Roon ready devices that support gapless playback. I haven’t found one yet.


That’s not the case; Roon delivers a gapless stream to Chromecast devices, but it is reliant on having a network with good real-time response. See:

Hi Walter,

I found this post:

if you search on gapeless, you will find a post Ray Von. He wrote that the Pro-ject should be gapeless as a Roon Endpoint, but no gapeless playback over DNLA.

Know expert, but after reading the post i got the idea that DLNA is over Wifi.

Kind regards,


Hi Geoff,

Then, that is strange.

I have 1GB internet connection and my Roon end points are connected via Ethernet.

The chromecast is the only Roon endpoint in my network connected via wifi and it is in direct view of an Ubiquiti access point. My pro-ject ultra streamer is Roon ready and connected via Ethernet also but no gapless playback.

What gives then?

Thanks for any help and advice.


Thanks! I will take a look now :slight_smile:

If I understand your setup, you are streaming to the pro-ject ultra via ethernet, this is connected to your Chord, which also feeds your wifi-connected Chromecast.

This being so, the first thing to investigate is why your pro-ject doesn’t seem to be coping with the gapless stream from Roon.

As an aside, I have multiple endpoints, including a Chromecast Audio using wifi. All are playing gapless…

That is correct. No clue why it is not gapless. At the end of each song there is a silence of approx 5 seconds. I checked the links and info provided above but nothing I can do or change from there.

My internet connection is solid. The project streamer connects to the chord qutest via usb while the chromecast does that via optical connection.

Have you setup your end point to mute for a period of time to get rid of clicks and pops?

Hi Henry,

I don’t think so. I wouldn’t even know how to do that. How could I check what you are pointing out?


Well, there’s Resync delay in the Audio device Setup (see the article below), but that should only kick in if there is a format change between tracks. A gap of 5 seconds between every track is very bizarre, and certainly not normal.

Resync delay was and still is at 0ms. Anyhow, the fact that all end point regarding of their connection and specification are non-gapless indicates that it is probably a Roon internal issue. Is there anything else I can do?


All your endpoints? I thought that your endpoint was a single chain: Roon core → Pro-ject ultra streamer → Chord qutest → Naim NAC 202.

What’s your Core running on? If it’s a Windows PC or Mac, set up the system output as an endpoint and test that. Alternatively, you could also set up the system outputs on an iPad or smartphone and test for gapless on them.

I also have a bluesound speaker that is also Roon ready and a pair of apple HomePod mini. But my main hifi stereo has the pro-Ject streamer and a chromecast connected to the chord dac.

I tried with the iPad as an endpoint. Nada! Same thing with a delay in between tracks every single time.

My dedicated Roon core is an intel NUC 2 years old with 16 GM of Roon core is connected via Ethernet to my router/modem. Connected to my router is a switch from which I run multiple Ethernet connections across my house.

Then there is definitely something amiss in your setup. 5 seconds between tracks? That’s not a gap, that’s the Grand Canyon…

I confess I’m stumped. Probably best that @support pull some logs from your system.

Appreciate your help. How do I reach Roon support?

You will have by posting here in the #support category of the forum. They get notified by the system for every new post. I’ve also flagged them explicitly for you by using the "@"support tag.

Probably worth while bearing in mind that they are a small team of 4 people, and their queue is likely to be long because of the recent launch of Roon 2.0 and ARC.

That is excellent! Thank you so much Geoff.

Best regards


Just a thought that occurs to me - have you tested with an album that you definitely know has gapless tracks, e.g. Pink Floyd’s Dark Side of the Moon? Or an opera that has been recorded with gapless tracks?

Most albums do have silence padding at the end of their tracks, so that when played a gap is introduced, even though the next track immediately follows the previous one.

1 Like