Getting Allo products to work with HQPlayer NAA

Hi. I need your help please.

I bought first Allo Digiplus signature and put it with a RP4 and it worked well. Sound is good but could be batter in comparison to other SPDIF cards I bought later on from hifiberry which are at a fraction of the Allo price.

Anyway, the above is not the issue as I wanted as HQPlayer NAA end point. So, I bought three USB bridge units with digiplus signature. two for my friends and one for me to use it mainly with Hqplayer. My friends are using theirs with Roon for now and they are working fine with Dietpi.

The problem is mine also works well with Roon but with Hqplayer NAA it gives this ugly static noise with the sound. I contacted their support and they send me a new driver for the network but that did not solve the problem. So, I appreciate anybody’s help. The noise comes with PCM and DSD upsampling but more with DSD. I have Chord Dave.

What is disappointing is Allo’s support. The person seems not to know how to use Hqplayer and giving me generic answers. I guess they know their product is defected and is incapable to play NAA Hqplayer but they do not say that. The USBBridge I guess is based on RP3 which has this serious issue of sharing the same controller between network and USB which is solved in RP4.

Any advice please before the next action with Allo.


First, Allo is a hardware company. They supply some front-end fanciness to DietPi but otherwise don’t expect much support beyond the hardware.

I say this because what you describe is software issue…

What software are you using? DietPi? With what version of NAA? Need more details here. Have you tried any other OS / NAA combination?

Not entirely true. It uses a Compute Module 3 which has similar SoC but a different layout for peripherals like USB. My understanding is that the Digione Sig USB design overcomes the USB limitation in the Pi3 (as long as you use the USB port on the back near the ethernet jack).

My advice is change the OS. I don’t use NAA so I don’t know what current recommendation is for OS / NAA combo is. Any OS should work with the Bridge Sig as the OS just sees the special USB port as another USB port. No need for driver (unless the Dave requires a driver, I don’t recall).

Hi and thanks for the reply.

I tried both Dietpi and Volumeo and both gave the same issue.

I guess it is a hardware design issue that the USBBridge is incapable to power NAA. I am using the latest NAA version. RP4 works perfectly. When I login to to the USBBridge through SHH the noise increases when I issue any simple command meaning the processor and the network bandwidth cannot support the high bandwidth required by NAA. When I increase the processor speed the noise becomes less but does not go away and that is a clear sign of the hardware incapability.

Saying Allo is a hardware company does not make sense as hardware does not work without software.

What do you think? can you use hardware without software?


What I mean by this… They expose standard interfaces to the software. Allo isn’t tweaking anything special in the software drivers to make their hardware work. To the software, it’s just a USB interface on a Pi. This is unlike some other manufacturers, like Sonore, that require you use their software because it’s the only thing that understands the proprietary board they use.

So, my obvious question is… are you using the right port on the USBridge? You need to use the one on the back near the ethernet cable. Then, what exactly are your HQP settings? I’m not an HQP expert but you certainly could be hitting the limits of the Allo design. If you were to talk to Allo again I wouldn’t even tell them you were using HQP. I’d just tell them what bit depth / resolution DSD rate you were running and ask them why it doesn’t work. That is really all they should care about.

Hi. Thanks for taking the time to write this reply. I am not sure if you are associated with Allo but please see my points below:

  1. Sure I am using the correct USB port.
  2. Allo also use network proprietary drivers and they send me the link the download theirs but did not help solve the problem.
  3. Allo is not reinventing the wheel here as they simply use RP platform but their USBBridge seems so old and done at a time before RP 4 came. I guess they are selling an old absolute product. They should put a message not to buy this if you plan to use HQP NAA.
  4. Allo support is so poor as the person has no clue understanding the issue even.

Please note that I bought 4 units of USBBridge and stuck with them all. I bought another NAA endpoint from a different brand based on RP4 and it works perfectly.


I have no affiliation with Allo other than owning a couple of their products.

  1. They don’t. You can load any CM3 supported image and it will work.
  2. This isn’t entirely true and requires an understanding of what the Raspberry Pi Compute Modules are…

This is the doc sheet for the CM3+ which is what is used in the USBridge Sig.

You’ll notice that this is a DDR2-SODIMM socket SBC. It is up to the manufacturer to supply the I/O board to the CM3+. So, while the “brains” of the USBridge Sig are standard CM3+ the carrier board is completely designed by Allo. But, they must design the I/O to function with the CM3+ to be compatible. This is why any OS supporting a CM3+ will work in a USBridge Sig. As far as “reinventing the wheel” well, yes, the I/O board is completely proprietary to Allo. That’s the whole point of creating a “clean” USB output. You can see that the CM3+ has 2 USB lanes. It’s unclear how the USB Bridged utilizes these (does it use just 1 or both) but that’s why any software will work. The OS uses a standard driver and then the manufacturer just builds the board around that lane. The other thing to note is that the CM3+ has no onboard ethernet so, just like the Pi 3, ethernet is implement as USB off one of the lanes. You’re right, the USBridge Sig was designed as a carrier for the CM3+ so it absolutely holds the limitations of the CM3+. However, those limitations are different than the Pi 3 SBC.

  1. This is why I say they are a hardware company. They don’t really know, or I have seen, great support for the software running on top of their hardware. You’d have a better chance reaching out to Signalyst and discuss your issues. They’d have a better understanding of where the limitation is.

I’m not trying to defend Allo. In fact, all of their transports could use a bit of a refresh at this point. The USBridge Signature was launched in October 2019 and announced a few months prior. It takes time once a CM is launched to get to production ready on a carrier board. I assume they may release a carrier board that uses a CM4 but the CM4 is a completely different animal then the CM3 (you can look at the datasheet).

It seems you have good level of details more than their support team. As I appreciate all what you wrote, the following is my experience:

  1. I tried both Dietpi and Volumio and both have same static noise issue when used.
  2. it seems the clean USB is sharing the same network bandwidth or does not have enough bandwidth for HQP NAA support. It plays well up to 192khz.

My advice is to try to use it with HQP NAA if you have one and you will discover that it work not work and give the same static noise. So, all what I am saying is they should stop selling the USBBridge as an HQP NAA end point as it does not meet the spects.


My i suggest u try… RooPieeXL for the HQ Player NAA function. I use it woth no problem at all. It plays from MMM1 > Allo via ethernet cat6 cabel.
Audio format is DSD512…Data stream in mb is around 45mb/sec.

Try Google it, do a flash on sd card and try

Thanks. Will try RooPieeXL. I am not sure if I missed anything, bute after I moved to DietPI I got batter sound. I find DietPi more advanced. However, will try RooPieeXL one more time when I have some free time.

At this time I am not using HQP as I am enjoying the music more without it, at least for now. and To be fair to Allo, the SPDIF and USB from the USBridge using Roon are amazing.