Getting Roon to recognize CD's ripped to NAD M50.2

I have been going back and forth between Roon and Kyle F at BluOS trying to get Roon to recognize the CD’s that I have ripped to my NAD M50.2 CD player, with no success.

Kyle F. at BluOS advised me to go to Settings in Roon and add the networked share location for the NAD M50.2 which is (confirmed by Fing software on my i-phone) He said to enter\\Shared but when I do so using my desktop computer, a message comes up “There was an unexpected error: Invalid Network Path”. I have tried this several times with the same result. Are the delimters he suggested using for the address correct? Can you help me with this problem?


You should try smb:// and its often case sensitive for the share name too so /share and /Share are different.

You need to do this in the Storage option under Settings in Roon Remote. this can be on the Roon app on your PC/MAC/iPad etc

more info here’m_having_trouble_setting_up_my_NAS

I did try smb:// and a message came up with “There was an unexpected error: UnexplectedError”.

Do you have any other suggestions?

Try smb://



That doesn’t work either.



Kyle from BluOs took remote control of my computer and used \\shared to get Roon to recognize the CD’s on my NAD M50.2 CD player. Note that the IP adress kept changing. I was not using “guest” as the Username so there was also operator error on my part. Sorry to bother you. The problem now appears to be solved. Thanks for trying to help.


1 Like

Using fixed IP addresses for these kinds of devices like servers and shared file systems is always best. it could be setup in the device itself or done via the router when it sees that MAC address connecting and assign a fixed address.

on another note to put a \\ you need to use 3 \'s together in the forum to make them display as 2 and 2 \'s to make it show as 1 \

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.