Going from KEF LS 50 W with Roon Nucleus to Devaliet 400


I bought the Nucleus 4 monts ago and it has been playing flawlessly with Kef Ls 50w and Kef KF 92.

The NUC is connected into a Router and everything is playing through wifi.

Yesterday I upgraded my system to the Devaliet 400 with passive speakers. It should bee a seamless integration I thought. It gets static, stuttering and stop playing. It can be from 0 sec to 1 min and the problem occurs, the first time I tried Roon with it. Really disappointing!

I did use all evening yesterday and whole day today, now I have reach a point that I need help. It seems that the wifi integration between NUC and Devaliet will not work as it should.

The Dev works with my (TV, Apple TV, Xbox X connected with Toslink, but not with Roon. No way!

Or should I say it recognises it, plays music in some sec and then it is like a interference or something ruin everything.

The Dev is exactly the same as my is 50`s wont connect to other than 2,4ghz.

This hasn’t been a problem with the Kef and I don’t think this is the issue now. I’m new to the Devaliet, but we configured it yesterday and I don’t find anything wrong?

Can someone please chime in.
Best regards

Wireless connection is never the best practice for connecting if it can be avoided at all.
Can you try a wired connection as a test?

Also what are you trying to play?
Local files or streaming?
And what quality if so, 44.1,48,96,192?

Hi Ace Rimmer.
How do I connect it with a wire?
I`m using local files 44.1 24.48 256 not higher than this.

I assume the Dev has an Ethernet wired connection option?
If so I would take it direct from the same router your nuc is connected to if that is possible.

yes, one in each. Should I use the master or the slave? Problem is that I do not have any cat wire here laying around. I didn`t think this would be a problem considering Roon and Devaliet cooperates. If I going to try this I need to go out and buy the wire.Not poosible on a sunday

I’m really not familiar with the Devs but I would say the Master.
Roon really do not recommend WiFi connection and the Cable would be a very good test in my opinion.

ok, I found one, where to put it in the router. I have 3 free spots

I would say any should work if they are all live Ethernet.
You will probably need to configure the Dev for wired and not WiFi too

thanks for the advice, i tried the wire, but as you say I need to configure first. I red in the Devaliet forum of people with the exact same problem back in 2017 that they felt it was a interference problem, Like if the frigerator turned one, it will have impact on the sound. Strange! never heard of something like that, but it seems right.
So I started to look into how much devices I had connected to wifi and then turned off the mac, Xbox x and maybe it was slightly better, or it held up longer before it f…up again.
I will post in the Devaliet chat forum tomorrow to see if someone have more experience with the devices and the now how.

Hello @Anders_Grue. Posting on the Devialet Chat forum is a good plan (I’m a member there too); it’s a fairly friendly place and there are plenty of people who will be happy to help.

Wi-fi has never been a strength of the Devialet amplifiers unless they are literally within a couple of feet of your router (or a wireless extender). It can work OK for control (via the app) but is often not reliable for streaming.

Yes, if you’re using a wired connection it’s just the master you’ll need to plug in. The Ethernet input on the master will need to be enabled using the configurator if it isn’t already.

There are several methods by which Roon can talk over a network to a Devialet. Since you have a 400 it’s likely to be using Devialet’s AIR protocol. The first thing to find out is whether you’re using Devialet’s AIR “virtual sound card” driver on your NUC, or whether Roon is talking directly to the 400 using its own implementation of the AIR protocol. Most people find that the latter approach is more reliable. Looking in the Roon audio settings - maybe posting a picture - should help to answer that. Alternatively, if you look in Windows Task Manager to see whether or not there’s a Devialet AIR process running that might give some clues.

Hope that helps a little.


Glad to have a Dev “expert” chime in here to assist. Thank you.


Also, when you enable the Ethernet in Devialet configurator, it is recommended to disable the Wi-Fi.


Hi Ian!
Thanks for the suggestions.
I tried with ethernet cable for an 2 hour period and just had 3 small interaction/dropouts. I can live with that, but my cable will run straight over the floor in my livingroom thats not cool! The Router is 2 m from the Devaliet and the room is splitted with the ouput in the wrong wall.
When I looked into Roons audio settings I can see that it uses air.

Now I have been out for a while and I was willing to try without cable connected and it works for a much longer time, small hickups, one totally stop but much better overall. This is headscratching!
I`m going to use it as it is and see if its getting better. It is unstable either how.
Thanks for all help.

Thanks for the update.

You might want to try experimenting with the buffer size Roon uses to send data to the Devialet. In Settings->Audio, find the Devialet AIR device and click the gear icon to the right of the device name. Then select the Device Setup option. If you then show the Advanced settings you’ll find a selector for the Buffer Size. Try setting it to a high-ish value, perhaps 2000 ms, and see whether that improves things.

Other than seeking the ultimate SQ was there any other reason to move from the KEF’S

I am mentally debating the KEF LS50 Wireless II vs a Cambridge Audio CXA81 and the KEF LS 50 Meta Passive speakers , any comments ? (Money not a consideration at this stage)

I’m definitely not an audio expert, but I am an IT expert ( sorry for lack of humility here…I’m a former cto for a global company) but Ethernet connections will always trump wifi…a wherever possible connect the key components by wire (and your switch/router *will * make a difference…reply for more details…cheers Steve

Hi Ian!

To raise the buffer size didn’t help at all and so to not start a hassle journey, like I had when connecting Roon the first time, I bought a 9 m long ethernet cable and now I’ve experience small dropouts here and then.

Much more stabile. I leave it with that.

Thanks for all help.

1 Like

Yes I stick with that. You`re perfectly right.

Hi Mike!

To me Kef sound is really open and airy and crystal clear, Best speaker I’ve ever had, until now.

I`ve bought the bigger brother floorstanding speaker Kef Blade One (no Meta). Why is that I’m going to move to a house in some months and will make a listening room there.

The huge widening soundstage they provide is amazing. The more you cranck up the volume the better it gets. When listening to music I like to sit between the musicians almost touch them, This is music nirvana for me.

Back to Kef LS 50w, they need a sub! When you connect these two units, it’s not far away from the Blades. Try demo it and you will understand.