Had to change my Arc Port manually to 55000

Hey Folks,

in case this might help some:

After taking care of the port forwarding in my firewall I was still unable to get Arc to connect to the Roon server.

Solution: I manually changed the Roon Arc Port Number to the default value of 55000

This may be of interest because, perhaps like on my Roon server, the Arc Port was NOT set to the standard value automatically - on my Roon server it was a completely different port number which I don’t know how it got defined…

Changing the port to 55000 (and ofcourse since I defined the port forward in the firewall with port 55000 as per the Arc configuration FAQ) resulted in a working Arc. Yay!


My experience exactly. Arc is a game changer, just need to change the name to Roon Mobile. ARC is particularly useful since I have items in my collection that aren’t available through traditional streaming services. Big Kudos to the Roon staff on this release.

Same… it was 41909… but not sure why that didn’t work when I had all my port forwarding set to it. But manually setting to 55000 and doing the port forwarding again it worked.

i’m fairly savvy, i think… ahdunno, maybe not…

but how are you knowing what port to set the forwarding to?

(haven’t upgraded yet, just asking the questions.)

does anyone know if DDNS can work with Roon?

What do you need DDNS to do?

ARC doesn’t care whether your Roon Core (or, more likely, your home router) has a DNS entry. It presumably gets the IP address by querying Roon’s servers.

Roon - Settings - Roon ARC. You might need to click down arrow to see the port number.

I don’t think so based on my experience; it seems it updates the address + port it’s available at when you’re in the ARC setup box. So DDNS itself won’t help - if your IP changes, you’ll need to open that setup box again for it to update your available address. Not confirmed - just my present experience.

yeah, ok so I updated and tried to install/run ARC

tried entering 55000 but no go

getting the “can’t find network” error

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xx.xx.xx.xx”,“router_external_ip”:“xx.xx.xx.xx”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

figured best to hide my public ip

FWIW having to match the default roon port makes me think it’s an issue with the local firewall on your roon server.

ok, hmmm, how to fix?

2012 mac mini, running catalina…

I’ll open a support thread

Do you have multiple routers with router behind router or simply a single router?

i have a comcast modem/router with a public ip address, 10.1.10.xxx internal

goes to an Eero wifi network, with 192.168.x.x addresses

I put in a range of 55000 to 55002. I don’t remember for sure why I had to do that. My number was 55002

roon core has a static address, and the eero interface allows me to do port forwarding right to that device.

Seemed straight forward, and thought, this will be the ticket…

but no go

EDIT: tried 55000-55002 and no go

You need to get the Comcast modem into bridge mode, you are double NATed right now.

1 Like

ok. see, this is the stuff… how does a normal person know how this has to be done?

thanks, stand by

1 Like

Seems like a variation of double NAT setup.

Others said that won’t work, I would think double port forwarding should be possible but probably only by manual configuration (so no UPnP).

Forward port 55000 from ISP router to (static IP) address of WiFi router and same port from WiFi router to (static IP) address of Roon core.



Call Comcast and see if they can and will put their modem in bridge mode for you.

1 Like


Ok, that worked.

Went into my comcast modem (admin interface at, should be same for all) and changed it to Bridge Mode.

then went into my Eero app, found the roon core on the network, and opened port 55000.

Thank you!