Has there been a change in editing in 1.3?

I ask because I seem to have had to go through a lot more steps than previously to get the album below corrected.

The issue being the album don’t explain was ripped into the same folder twice with slightly different metadata so dbpoweramp must have been fooled.

The first thing I did was go to the “fix track grouping” and i selected the duplicates at choose to remove them. This has worked previously for me, but not in this case.

So I went back to the original data and deleted the excess tracks and chose rescan album… no change, still 2 tracks showing. I then did a clean library with a similar negative result.

I then moved the album out of the watched folder fully, but it still was showing up and in duplicate and rescan didn’t change this. So the I did a full “force rescan” on the watched folder and this got rid of the album.
To be sure to be sure I did a clean library again and I added the album back into the watched folder again but now the album wasn’t showing up at all.
A “force rescan” got it to show up and correctly.

Previously if I moved albums in and out of the watched folder they would appear and disappear immediately.

None of this is a big issue to me, I was surprised though that Roon seemed to be acting differently than I remember.



I think there were some changes here in 1.3. I shifted this in to Software (we’re trying to keep Support as an Emergency ward), but let’s flag @mike anyway and see if he can guide us through the best approach here.

1 Like

@RICK_VANDENPOL asked me a similar question recently. I’m going to take a look and see if we can do better.

@Sloop_John_B – any chance you have a folder of this media in it’s original form? I assume you had two copies of the same album in the same folder?

If you have the media, it would be great if you could zip it up and upload it somewhere for us – @RICK_VANDENPOL, you as well.

Can’t make any promises because I need to look into why this behavior changed in the first place, but I’ll see what we can do here.

just to say that so far only consistent way I found to have Roon pick up changes is… quit and relaunch
Force Rescan, weirdly, not always works :neutral_face:
(files on a NAS, if it matters and… I believe it does :wink: )

Luckily I have beat my backup to it so I’ve sent you a dropbox link to the folder with 2 copies of the album.


Just edit changes or is it the same for adding albums?


after editing tracks/albums already in library
to add new ones force rescan does it :slight_smile:

I run a Qnap NAS for storage and a Windows 10 laptop as core, when I add an album it is there instantly in fact the artwork is there in overview while the tracks are still copying, wonder why you don’t get the same?


no idea!
it’s always been like this: Roon adds almost istantly every new album but just two/three tracks are there :neutral_face:
must trigger a force rescan to have them all show :frowning:

I experience the same speed / response as Russ, but often the metadata is slightly odd, or the files are highlighted as ‘corrupt’.

But I always improve the metadata with Discogs / MediaMonkey directly after the rip anyway, force rescan, and everything’s perfect…

@mike I have come across another album, Otis Blue that for whatever reason I had 2 rips for each track in the folder (one set prefixed with 01,02 etc.

So what I tried was deleting the 01,02 tracks.

This is what I end up with

I’ve cleaned library and forced rescan, neither resulted in a change.

Looks like I’ll have to remove album fully and reinstate (after cleaning) to get this correct but as I say the opening post this seems like I have gone back to the future with respect to editing.

I’ll leave as is for the moment in case you want a look at anything.
I appreciate with Win 10 not working after an update that this is small fry, but I’m just giving as much information as possible so that when the time comes there is adequate information to try and figure what’s happening here.


I think we fixed this in yesterday’s release @Sloop_John_B – let us know if you see this again.

Thanks for the report!

1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.