Have Sound From System Output, Not Through Network on Allo Digione

I’m using Windows 10 x64. I have sound through my Juli@ soundcard on the core computer, but not through my Allo Digione. Perhaps I don’t have it set up correctly. I have the core computer and the Allo each plugged in via ethernet to my Comcast internet router. Roon sees the Digione in the networked audio area. It says bcm2835 ALSA, shows what version of dietpi and linux. I’ve enabled it but when I go to play music the networked endpoint isn’t shown ii the list of audio devices shown.

I don’t think you have enabled the digione. Can you post a screenshot of the audio settings showing the digione?

Hi Tony! Screenshot below

Screenshot (4)|625x500

Not seeing the digione there. Have you set it up as the audio device in dietpi? Here is mine

Oh. I didn’t know I had to do something other than plug it in. Could you point me to an instruction path that I can follow to do what you did?

Did you purchase the DigiOne “à la carte” and add it to an RPI yourself, or did you get the pre-assembled DigiOne Player?

Ssh into dietpi user root password dietpi. Enter the command dietpi-config and configure audio as the digione and ensure roonbridge is installed under software enhanced

1 Like

Orgel, I purchased the all-in-one RPI/Digione.

Tony, thanks. I’m off to go find out what all that means.

In that case they should have already set it up but it looks like they may have missed something. Are you a Mac or pc user?

I’m on a PC. I’ll contact Allo.

Is there anybody who works there that hangs out here? I tried to contact them about with a question a couple of weeks ago and never heard back from them. I think my Roon trial will run out soon, maybe before I can sort it out.

When I look through the files on the pi I can see roonbridge and raatserver folders.

Hi @allo.com, Johan, can you help out?

Cheers, Greg

It’s easy enough, on your pc download a free app called putty. Then using putty ssh to your RPi using the IP address of the RPi. Login with user root and password dietpi. Then enter dietpi-config and you will have a crude menu to set the audio device etc.

i’m trying to figure out what rpi ip is. Not my skill set. I would have paid somebody long ago but I was operating under the premise that the thing was already good to go.

@Tony_Reimann’s SSH instructions will work fantastically well, but if you have trouble with them, you should be able to use the Allo GUI:

In your web browser, go to “dietpi.local” and log in.

Username: admin@allo.com
Password: allo

Scroll down to where it says “SYSTEM SETTINGS”; you may have to click on the “disclosure caret.” Once you can see some subordinate info under system settings, one of the lines should start with “Soundcard.” If it doesn’t say “ALLO-DIGIONE” on the Soundcard line, then click on the “View” button, and you’ll be able to select the DigiOne as the soundcard on the page you’re taken to. Then click the green “Reboot” button at the bottom of that page, wait for the RPi to come back online, and you should be set.

(Having written all that, I think SSH might be easier.)

I went the ssh route and the unit didn’t appear to reboot. After some time I unplugged it and plugged it in again and now I have no led’s turning on.

It works and it sounds terrific. Thanks so much to you guys

1 Like

Glad you got there. The more you do this stuff the easier it gets. :grinning: