Having difficulty connecting Ropiee to Wi-Fi? Does the X20 after the network name have anything to do with it?

Roon Core Machine

Good day, I’ve installed Ropiee on a Raspberry Pi 3+ with a Justboom DigiHat and I am currently having difficulty connecting Ropiee to Wi-Fi. The problem seems to be that the network has an added ‘X20’ after the actual network name. Previously that X20 was not there and it worked flawlessly. I have rebooted the device and re-flashed Ropiee a couple of times. Any ideas to fix this problem or what the X20 means?


Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi Peter, I don’t know what would be the cause of your trouble, but I have just moved your thread to the RoPieee category on the forum. Here the chances are better someone can help you.

Welcome to the Roon Forum!

This is likely an encoded space character:

\x20 \040  32

I assume that your SSID doesn’t have a space at the end of it? I’d check your router to be sure.

Also, I’d try turning off wifi, then save, and then reboot (only with ethernet). Then re-enable wifi, reboot, and join your SSID entering in new details.

If those steps do not help, you could try submitting feedback so Harry could take a look at your logs.

Something else to bear in mind is that your RPi’s IP address will change when you switch it over to Wi-Fi, even if you have a DHCP reservation, as the ethernet and Wi-Fi adapters have different MAC addresses.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.