Having to choose between MQA rendering or gapless / crossfade playback... because of my iFi DACs. Not support related, more of an FYI

Roon Core is a Mac Mini and I have four endpoints… two are iFi DACs (Hip DAC and Zen DAC) and the other two are simply digital out to a AV Receiver (no MQA).

On the two iFi DAC endpoints, crossfade and gapless works fine on MP3, FLAC and DSD audio files but with MQA files, there’s a half-second gap. With crossfade enabled, it does the crossfade but the same split second gap exists then it plays the overlapped audio. Without crossfade enabled, there’s a gap that’s rather annoying with live performances or albums that are meant to be gapless. I would even say there’s a “very slight” pop sound between tracks… which funnily reminds me of a record needle dropping on an album. LOL.

On my non-MQA endpoints (and the iFi endpoints with MQA set to “not supported”)… gapless and crossfade work just fine, even with MQA files.

I also tried with upsampling and convolution turned off, but same result.

Side benefit is that with MQA turned off I get to take advantage of DSP upsampling since it’s ignored on MQA files.

And please, no MQA debate conversations in here other than MQA discussion around which DACs (if any) support crossfade and true gapless playback… I’m wondering if it’s my iFi DACs or any MQA DACs in Roon due to how MQA files are authenticated/processed/rendered.


Hi, got more or less the same set up and the same problem…

I have the same issue with an Exasound Playpoint streamer and e32 DAC. They fully support MQA, but I’m trying to sort out the settings for cross fade and gapless playback. No problem with gapless on my SMSL DAC attached to my computer, or with the toslink output from my monitor to the same Exasound DAC.