HELP! Arc network issues

Roon Core Machine

Nucleus

Networking Gear & Setup Details

Linksys Velop mesh router
Ethernet
No vpn

Connected Audio Devices

Ethernet to stack audio link streamer

Number of Tracks in Library

10000 about

Description of Issue

Upnp enabled in my router, but not connecting.
Arc connection issues:
{
“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“112.206.72.169”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“10.147.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}
}

Hi Miguel,

Friendly fellow user here. Sorry to hear about the issues you are having in setting up the exciting new ARC features in Roon 2.0.

Are you running two routers? One from the ISP and the Linksys? If so, you might have a double Nat happening. One option is to set one into bridge mode. Another option is to manually port forwarding rules , one from the first router to the other, and then the other to the core.

See FAQ for some additional suggestions: https://help.roonlabs.com/portal/en/kb/articles/arc-port-forwarding#Multiple_NAT

having the same issue. clicking on Roon ARC tab to connect gets me this:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“108.89.173.169”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Have the same topping


Router d link dvg-n5402g

Folwed Roon instraction contact network provider with no luck

From another thread -

Hey thanks for the reply, it’s not double NAT, but just found out my ISP doesn’t allow port forwarding…no Arc for me I guess

Well, you can always call them and see if they can give you a static ip.