Help getting Roon running after a settings reset on Qnap

I made some big mistakes trying out Virtual switches on my Qnap, while configuring a new router with VLAN and ended up having to do a full settings reset (kept user data). I got everything up and running again except Roon Server. It installs but I can not access it from any clients. Let “Looking for your Roon Core” run through a whole night…

System: Qnap TSV-471, i3-4150 @ 3.50GHz, 4GB ram, SSD disc on slot 1. Firmware

First time install was before Roon ended up in AppStore. When opening the app in Qnap it has always been blank/ no info, before and after settings reset.

I have tried several times to reinstall, with different scenarios for example deleting RoonServer folder and creating it again before installing with no good results. Configuring Roon Server on my Mac I can access it from clients on same VLAN so there is no networking issues that I can think of.

Is there any thing I can try before I do a complete re-install of the whole NAS?


Are you sure the QNAP is on the same vlan as the rest of the audio gear and control pc. Roon can’t traverse vlans and this very much sounds like this is the root of your issue.

Qnap is connected to the VLAN that my mac is connected to. I also tried connecting one of the Qnap network ports to the for wireless access to test my app on the phone. So no luck connecting to one or several VLANs.

Biggest guess is that there is some hidden folders that was not deleted and now contains faulty data…? Like when I reinstalled Wordpress I had to Initialize database and then re-install wordpress to be able to start configuring again…

Have you tried turning all VLANs off.

I configured VLANs a couple of days after I reset the Qnap so I have tried to get Roon working without VLANs…

Edit: Seems like the intro text is easy to misinterpret… Sorry. The new Router is a Ubiquiti Edgerouter ER-4 that I had running with basic setup for the first couple of days. Listening to music was a bigger priority than getting the VLAN up and running, but after reading a lot on this forum and hitting the wall to many times I switched priority…

I basically only have the NAS system with Roon, empty Wordpress and some minor tweaks on HD1 so I will do reinstall after disconnecting the other drives. Seems like a easy solution for me. I’ll get some new backup options if I reformat the drive anyway :slight_smile:

Thanks for the suggestions!