Help - Nearly all apps have disappeared from QNAP desktop including Roon, but Roon is still playing music

A few months ago I followed @crieke 's recommendation to enhance the security of my QNAP NAS by changing the default “admin” password to one of my own. Recently I saw the notice that an upgraded version of RoonServer for QNAP/Synology has become available. But when I tried to install it, I found that my QNAP desktop no longer has RoonServer–or any of the other apps that used to be there. Roon still works perfectly on my music system, but I do like to keep the software updated.

Can anyone help me get back to seeing all of the apps including Roonserver? I tried rebooting the QNAP with no improvement. I still see this:


I had the same issue Mark, Roon worked fine but I could not see the app. I had to re-enable the default admin, then go to the second admin account so I could add the App Center to the second admin account and then add apps. Once the App Center and apps were on second account, I disabled the default admin again and now all is fine. Hope this helps because it kicked my ass for hours! I have found that there are things you cannot do unless you are signed in with the default admin. I am not an IT person, so there are probably folks that know an easy way around this problem, but I don’t and I still made it work, which is probably the hard way. Or, you can always log in, re-enable the default admin, then log in with the default login, update Roon, then disable the default admin again.

1 Like

Thanks, Stephen. I tried to do something like that, but when I tried to log in with the “admin” user name it wouldn’t let me in, either with the old “admin” password or using the MAC address with no punctuation. Could you give me a really simple step by step description of what you did? I’m not a techie–though far from a computer novice–and I find the QNAP environment to be a little less than user-friendly. Thanks!

Log into your NAS with the account that gets you in. Then go to:
Control Panel
Click Users

Click the pencil in the Action box of the disabled account.
Uncheck Disable this account

Click OK, log out and log back in using the default admin account and you will see everything again. Just remember that the default admin is now enabled. Once you are done with your Roon update, go back to Control Panel / Users and disable the default admin account again. I wish I could walk you through getting the apps on your new non-default admin account, but I would have to undo and redo my NAS to remember the steps, sorry, but this will get you back to the default admin account so you can see your Roon app and perform the update. While you are logged in as the default admin, try adding the App Center to the secondary admin, once you have the App Center on the secondary admin, you should be able to add whatever apps you want when you are logged back in with the secondary admin account.

I updated my Roon Core through my desktop PC app

Hope all of this helps.

Hi Mark, I think you would be better creating another Admin user using this video. I have a feeling that you didn’t complete the process the last time. Follow this video and create another account, no need at this stage to remove or disable any existing accounts: - How to disable the admin account?|NAS FAQ - YouTube

There’s a lot of pop ups just complete every one of the recommendations and update any Apps that need updated. When completed you should end up with a fair number of default Apps on your desktop.

Once all of this completes disable the existing Default Admin user/users as per the video.

To add the Roon shortcut to your desktop click the 3 lines in the upper left corner of the Desktop screen and right click the Roon App to create a shortcut: -

If you get stuck or unsure get back to me.

1 Like

Damn! That an easy fix, Wish I had known about the three left hand dots, haha!

Thanks, @scotav that is a very helpful reply, BUT it doesn’t help my problem, because I don’t even have access to the Control Panel. Here’s what I see when I click the “hamburger” on the upper left:

Any thoughts?


It looks to me then as you are logged in as an ordinary user without administrative rights.

When you originally created the other account did you disable the default Admin account? I’m not sure what you’ve done but I think your default Admin account may still be active. If you can remember the details try logging into the original account and we’ll take it from there.

As BlackJack says it looks as if this is the account you created but you haven’t given it Admin rights. You need to get back into your old account.

Thanks, all, especially Scotav–all good now. Black Jack was correct–when I set up the new account as Chris suggested back in May, I evidently missed the part about giving the new account admin privileges. After a soft reset and following the YouTube video, I’m good to go.

Really appreciate the support of this forum.


Glad I was able to help.