Help with Arc port forwarding for Nucleus

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?
    Technicolor CGA4234

  3. Do you have any additional network hardware, like additional routers or managed switches?
    Google Nest WiFi

Netgear GS308 unmanaged switch

  1. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Apple HomePod (WiFi)

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

I just bought the Nucleus and set it up. It’s software is up-to-date. My music library is on a Synology NAS. Both connected by ethernet to a Netgear switch.

I want to use Roon Arc but get the error below.

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

The Technicolor goes into the Nest Wifi. The Nest Wifi goes into the Netgear switch. The Nucleus goes into the Netgear switch.

On the Google Nest Wifi I set up a Port Management rule:
Nucleus Internal 55000, External 55000 (TCP)

Device Mode is set to NAT (standard)

UPnP is enabled

IPv6 is enabled

Using Roon Remote on MacBook Air, iPad mini, and iPhone 13.

Roon Remote works fine on all my devices and streams to the HomePod no problem.

Any and all help welcomed.

Hi @davidmead,

First of all, as far is i know IPv6 isn’t supported by Roon Arc yet ( i’m no employee of Roon, just a fellow community member) so i would turn that of.

Is the Technicolor a modem/router combination? Is the Google Nest WiFi also a router? If so, i would suggest you set the Technicolor in bridge mode.

Kind regards,


Hi @Maarten_Duits :wave:

I turned off IPv6 in the Google Nest WiFi. I think that is just on by default. It didn’t have an effect when I turned it off.

The Technicolor is the cable modem supplied by my ISP (Breezeline). It is one of those WiFi/Router combo’s they send out. It was supposed to be in bridge mode already as I use the Google Nest WiFi as the router for the mesh network.

I will call Breezeline to double-check this is still in place.

Could you turn of the UPnP and do a manual port forward in the nest?

Kind regards,


Hey @Maarten_Duits

  • I turned off UPnP
  • Confirmed with ISP (Breezeline) that my Technicolor cable modem is set to Bridge Mode
  • Deleted and added new port forwarding rule (see screenshot) in Google Nest WiFi

After restarting the WiFi and Nucleus I get this message…

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

HI @davidmead,

Hmmm, i’m running out of options. I do have one which we could try. In the Roon app under settings → Roon Arc could you change the port number to ie. 44135. After you changed it in the Roon App, change your port forwarding rule to the new port number.

Some IPS’s block certain ports.

Kind regards,


Thanks @Maarten_Duits

I did try changing the port to 44135, but no luck :frowning:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hopefully someone from Roon can assist. Thanks for all the ideas.

On the WAN or Internet side / interface of the Google Nest Wifi, the IP of the Nest should match the 69 addresses reported in the Roon error. If not then there is a second NAT or your technicolor is not actually in Bridge mode.

That’s the next thing to check.

Hi @ipeverywhere

Looking in the Google Nest WiFi settings, the WAN IP starts with 192.

I don’t see anything start with 69.

How could I find this out?

Anyone have any other ideas while I wait for Support?

Still hoping for a reply from Roon Support to help with this.

I managed to get this solved.

Finally spoke to my ISP (Breezeline). They gave me the username/password for the cable modem.

I entered a port forwarding rule for the range 55002~55002 on both the LAN and WAN, pointing to the internal IP address of my Google Nest WiFi.

The Google Nest WiFi has a Port Forwarding rule, using the same port, to the Roon Nucleus.

I can now stream my library anywhere using the Roon Arc app :grinning:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.