Help with getting Justboom IR Remote to control Roon


(Bart Maguire) #22

Hi Harry, I have a spare Justboom Amp which i can send you, though I do not have a spare remote. @chris_rush has said he can send you a remote.


(Bart Maguire) #23

Hi Harry,
I have the Smart Remote now. Ropieee sees it as OSMC but it crashes when I try to use it.
I sent you feedback c9bc75bd7c7527ce


(Harry ten Berge) #24

I’m not sure what you’re trying to do here. Looking at the logs I see that you’ve installed an extension inside RoPieee.

I’m not able to help with that as it interferes with RoPieee’s software.

So to be clear: there is no need to install an extension. You do however need to enable RoPieee’s own extension.


(Bart Maguire) #25

Don’t know what happened there - I got the Smart Remote, plugged in the USB receiver and restarted the Raspberry Pi. Ropieee then showed a new remote, which it identified as OSMC. When I tried to use it, it crashed.
I didn’t install any extension. How do I enable Ropieee’s own extension?


(Harry ten Berge) #26

So what do you mean with “it crashed?”

Furthermore I see clearly in the log that a ‘Roon extension keyboard remote’ is installed and is trying to start. That’s something which is foreign to RoPieee and interferes. It should not be there.

RoPIeee’s extension is enabled in Roon, as with other extensions.


(Bart Maguire) #27

What I mean by crash is - if I press any of the other buttons on the remote nothing happens but if I press the power button the Raspberry Pi crashes hard but does not reboot.

I don’t know what other extensions I have installed, I have been trying to get a remote to work for some weeks, so today I reflashed Ropieee onto a new SD card and reinstalled it.
I also removed any extensions except the Alarm Clock and the Extension Manager, which I need for the Alarm Clock.


Still the same behaviour - Ropieee sees the remote as OSMC but it crashes the system when I press the power button. 2885eb6efade9c1e


(Harry ten Berge) #28

it’s not crashing, it’s shutting down. can you start with something simple like play/pause?


(Harry ten Berge) #29

Ok, had a look at your latest log. It is now not being recognized as an OSMC remote control.
Hence the commands like pause/play, volume up/down etc will not work.
However, the power button is handled directly hence the shutdown.

Do you have a link to the receiver you bought? Is this the Sennheiser I see in the logs?


(Bart Maguire) #30

Hi Harry, it is a Justboom Smart Remote https://www.justboom.co/product/justboom-smart-remote/
I see that Ropieee now has the Alarm Clock built in, so I have removed the Extension Manager and Alarm Clock, so now there is only Ropieee and the Ropieee Alarm Clock in Roon extensions.
I have tried Play/Pause on the remote, but it does not do anything.


(Harry ten Berge) #31

Hi @Bart_Maguire,

Can it be that you plugged it in after you configured RoPieee?
The detection only takes place when changing the config.

So… can you go to RoPieee’s webpage and hit the ‘commit’ button?
When RoPieee saves it config it will try to detect the remote control.

Thanks,


(Bart Maguire) #32

I did that - Ropieee shows the remote as OSMC, but nothing works.


The remote is working and paired with it’s dongle, because the power button will initiate a shutdown.


(Harry ten Berge) #33

can you send me a new feedback? because this is weird…


(Bart Maguire) #34

I pressed each of the buttons on the remote, while the queue was playing and then I sent you feedback:
52608494fa7ee1c0


(Harry ten Berge) #35

This is strange, because the device is properly detected…

Could you login and show me the file ‘/etc/default/inputlirc’?

Thanks.


(Bart Maguire) #36

RoPieee settings

EVENTS=’-n HBGIC
OPTIONS="-m 0"


(Harry ten Berge) #37

Really? That’s not good. You might hit a bug here…

Can you do quick test? Change the file so that the first line looks like this:

EVENTS='-n *HBGIC*'

Save it and reboot.


(Bart Maguire) #38

Sorry, the line already looks like that.
When I pasted it into the Reply box in Roon it re-formatted it.

#
# RoPieee settings
#
EVENTS='-n *HBGIC*'
OPTIONS="-m 0"

Now I have worked out how to use the pre-formatted text tag.


(Harry ten Berge) #39

ok. then i need to look into this further because the config is correct.
It is properly detected, but for some reason the service is failing.

So to be sure: you’re running a ‘vanilla’ RoPieee: so no tinkering and installing other stuff right?


(Bart Maguire) #40

I reflashed Ropieee onto a new SD card yesterday and have done no tinkering since.


(Harry ten Berge) #41

ok clear. Then I’ll look into it further why this is not working. The USB receiver you have is the standard receiver with the OSMC controller which I have at home as well.

Are you willing to do some additional checks if necessary?

Thanks,