Help with hardware (CUDA)

"Streaming SIMD Extensions 4.2" where SIMD stands for Single Instruction Multiple Data.

It is older instruction set from the times before Advanced Vector eXtensions 2. This was introduced on 4th Gen Intel Core.

Difference is that most Atom/Celeron/Pentium branded CPUs (all based on Atom core) have only SSE4.2 and lack AVX2 which would be over 2x as powerful for same clock rate. In very latest Atoms Intel introduced AVX2 to Atom also, since the core is same one that have already been in 12th and 13th Gen Core as Efficiency Cores.

Regular Fedora build is AVX2-only, with CUDA support. Then there’s the SSE4.2 build that doesn’t have CUDA support, it is for small Atom/Celeron/Pentium-based devices.

Regular Ubuntu build is SSE4.2/AVX/AVX2/AVX-512 with CUDA support. And then there’s AVX2-only build for Ubuntu as well, which is usually best option for all recent bigger Intel/AMD CPUs.

Debian build is mostly SSE4.2 with limited AVX/AVX2/AVX-512 support and also includes CUDA support. It thus works on wide variety of hardware, but is usually not quite as fast as the AVX2-only builds on Fedora and Ubuntu.

Ok very good and interesting information. I hit that wiki page during my self-study, but couldn’t connect all the dots (“sse” was referring to too many things). Thanks again Jussi!

Can somebody help with CUDA?

I do have new Hqplayer vers. 4.21.1 (arm64) version installed. Now under Ventura (M2) under preferences there is no CUDA option visible.

I would like to use DSD because i do have a Chord TT2. Which options do i have to set to get it?

Thx for your feedback.

CUDA is specific to Nvidia GPUs. There have been no Nvidia GPUs in Macs for a long time. Nvidia and Apple have long ago discontinued their co-operation.

so how do I set the preferences for my chord tt2 dac?

my actual settings are below.

It is best to send 705.6/768k PCM there. That will bypass the first digital filter stage completely.

Sending DSD to Chord DACs is not useful, because they will convert it to 705.6/768k PCM first before upsampling again to DSD-type data.

It is great from you to answer so fast.

Is it possible for you to send me a screenshot how the DSD settings and the preferences setting look like.

Thx in advance

Set DAC Bits to Default. And Default Output Mode to PCM.

Otherwise your settings are probably fine. You can experiment with different filters and noise-shapers/dithers. There’s some guidance provided in the manual that can hopefully help in trying to find settings that best match your use cases.