Help with HQPlayer new Mac Mini, NAA, ultraRendu


I installed the ARMversion software of HQplayer on my new mac mini. That went well/
I’ve created an HQplayer zone in Roon with the ip address of the new mac mini. That went well too. Nothing is installed on this PC other than Roon and HQplayer.

Opened up HQplayer desktop and clicked the little network button. The ultrarendu will not showup under the drop down tab of the output backend. Under Sonicorber App Switcher, HQplayer NAA is selected and is green. I switched it back and forth from Roon Ready to HQplayer NAA 10 times, same result. Roon sees the changes when I use the app switcher from the zone being changed from HQplayer to Ultrarendu. Rebooted the Rendu over and over, nothing changes inside HQplayer. Rebooted the PC, nothing different

To see if I could get better results, I tried installing HQplayer desktop on a Windows PC on the network. Same thing, the ultrarendu does not show up on the drop down. Both PC’s are hardwired.

A bit more history. I had been using HQplayer embedded on my Sonictransporter with the UltraRendu and everything worked fine previously. Not sure what could be the issue trying to run it on a seperate PC with the desktop version. Any ideas or suggestions?

If you still have sonicTransporter, make sure it is not powered up and keeping the NAA reserved.

On Mac Mini, check that WiFi adapter for example is disabled to avoid multi-homed situation where there would be multiple active network interfaces.

Are all these devices connected to your regular home network? Do not use multi-homed environments with multiple network interfaces and direct connections between devices - it will just cause these kind of problems without benefits.


THANKS! Should have asked sooner. Keeping the Sonictransporter powered off allowed me to see the Rendu in HQplayer.

I still need the Sonictransporter as my Roon core so I assume I can start it up now? In the event I decide to go back to just using the Sonictransporter and Rendu with HQplayer embedded, will I need to do something with HQplayer desktop to “release” it like I just had to do with the Sonictransporter? Or is this specific to Sonictransporter grabbing hold of the Rendu and not letting go?

It is the same with any HQPlayer. If it is configured to connect to a certain NAA it will keep attempting to do so when running. Who ever catches the NAA first keeps it.

If you select some other audio device/backend on HQPlayer, or shut down HQPlayer, it will let off the NAA too.

A couple more questions…

These are the settings I used and i get this message at the bottom of the screen and no audio out

I think I may have resolved it. The volume control in HQplayer was set to zero. I assume there is a way to disable the volume control? I have a preamp/amp so I really don’t need a volume control.

Just turn it to -3 dB. But never turn it higher than that!

If you want to get it fixed at -3, set both minimum and maximum volume in HQPlayer settings to -3.

1 Like

If I check off “Direct SDM”, that gets rid of the volume control all together correct?
If I were to do that, would I then select -3db in headroom management in ROON instead?

What’s the best way to go about this with a preamp involved? Do both ways accomplish the same thing?

For DSD sources yes since it removes all DSP except channel delays. For PCM it locks volume to -3 dBFS.

No, don’t do that. You get same thing with better results by setting HQPlayer volume to -3 dBFS.

Leave Roon DSP disabled and set HQPlayer volume to -3 dBFS.