HiFiBerry DAC+ HD and RoPieee

Hi there!

Is anyone of you folks using ropieee with a hifiberry DAC+ HD out there?
I am and ropieee didn´t work - the dac was not visible in roon-audio settings, but visible under general.

I tried ropieee and the XL…with XL airplay worked, but raat didn´t…!?

Now I am using HiFiBerry OS and it works fine…but ropieee would be nice because of the display support.

Any experiences?

Did you go into the user interface in ropieee and enable the hat? The Hifiberry DAC is there to select. I just checked. That should be the first place you start.

yes, I enabled the DAC in ropieee - and yes, the DAC2 HD is available…but then nothing happend…

Then I choose another DAC - just to try - saved and restarted - nothing…then I switched back to the 2 HD - saved and restarted again - and it worked!!

But just until I put my Pi to another place, its final place, and therefore had to restart it again…again no DAC in roon visible.

Then I did the same procedure again…choose another one…but with no result.

HiFiBerry OS on the other hand was working instantly.

Maybe I just try is one more time, with a new flashed drive…


How about the power connection? If moving it about changes the state that the unit is in then I would try a different PS if possible.

Can you send me feedback?

You can find that option on the ‘advanced’ tab.

So, something else. AFAIK there is no ‘DAC+ HD’.
There is a ‘DAC2 HD’. So what model do you have?
And what did you select at the HAT selection?

1 Like

You are right, @spockfish, DAC2 HD is the right name…witch I have and of course selected at HAT settings…

But do you have feedback?

Not yet…I am waiting for some new SD Cardsto arrive, to try some fresh installations of ropieee and ropieee xl…
I will come back then!

My cards arrived now…
I tested my Pi with both versions of RoPieee, with a fresh flash…and what can I say: Works like a brease!!

The only thing I got ist following:
Parallel to this thread I posted another, because my Roon iOS App crashes permanently, on all devices, after some seconds… Now I found out, that this only happens, when Wifi on my Pi is switched on.
Now I use Cable LAN only and also the iOS App is working fine now.
This did not only happen with RoPieee installed, also with HifiBerry…so this must be some not perfect network connection with the Pi itself I guess. Because if the iOS App crashes, the music is still playing fine…

So, finally ropieee works fine! - but I don´t know what the issue was, could not reconstruct the problem.

I’m wondering if it would help to assign fixed IP addresses to some of your devices like your raspi and Roon Core. I’m not a networking expert so others might have more insight if this is a reasonable idea. I’d expect that cross device sessions could be interrupted if an IP address changes unexpectedly. Seems like you may have some instability with your wifi network.

HI @Douglas_Gardner, I already have fixed IP´s for all my devices.

The strange thing is, that just the iOS App seems to be as sensitiv… Rooncore including playback does never quit or stop playing…

Might be interesting to reach out to the Roon team.
Because the app should not crash because ‘something’ happens on your network.

You are right @spockfish
Therefore I have a second thread with someone from roon included - pointing on the iOS crashes: