High CPU usage on mac

Roon on macbook pro (catalina 10.15.7) uses about 300% cpu. It’s been like this for quite some time, and wonder if anything can be done for this high usage.

Welcome John!

High cpu usage is a long ( > 1 year ) lasting problem for Mac users, not all of them however. Roon is working on a solution, so you have to be patient…
I didn’t want to wait and switched to a Nuc with Rock. Great performance and more flexibility to do other things with my Mac. This is not what you expected to read, it is what it is.

Cheers John.

Thanks for the info. I don’t think I have this issue until about a months ago. (been using roon for about 9 months). I used to setup core on synology, but switched to QNAP TS-873 with database on ssd. Roon on mac didn’t have this issue until pretty recently. Fan is kicking in pretty hard that it is almost bothersome to enjoy music. Hope it gets fixed pretty soon.

Hope Roon can fix it for you!

I would advise you to contact support

Cheers John

If you toggle WiFi on and then off it usually fixes the issue. It is believed that the issue could be related to the Mac’s T2 security chip. By the way it’s irrelevant whether you are connected by WiFi or Ethernet.


This seems to do the trick. I turned on the wifi and CPU usage drops to around 40-50 range. I, then, turned off wifi and it seems to stay that way for now. No more loud fan noise! Thanks!

This worked for me as well. Thank you!

Mine only recently started doing this. I doubt very much it is the Mac. Mine goes up to 700-900%. The fan ruins the music.

I am still waiting for support to get back to me about two files Roon will not play on a specific album. 6 mths maybe.

So the message I am getting is tough, buy a different system. Again. I paid a lot for the Mac I use solely for Roon. I use this MAC for all my other stuff. An Imac for my photography. And an other MBP for going away, with small ssd.

macos 10.15.7
iMac 2019
Roon 1.7 (build 710)
Running off of ROCK 1.7 (build 710)

Roon is over 270% cpu for over an hour while nothing is playing.
RAAT is over 100% while nothing is playing.

Fans are spinning…

Turning wi-fi on & off did work for me ( don’t know why, though). Didn’t have any issue after the initial fix. I will post if i see any unusual behavior.

Wifi not on. I’m connected over wired ethernet.

Doesn’t matter whether Ethernet or WiFi toggling seems to work. Possibly causes some sort of reset to the T2 chip?

That is weird. I turned wifi on and CPU usage dropped to the single digits. Turned wi-fi off (because I don’t use it) and usage remains low/normal. Bugs are fun :wink:

What do you do if you need the Wifi to stay on? This is my main way of connecting to the internet, I’m in a big house.

Just toggle off and back on. It doesn’t seem to matter whether WiFi is on or off, just the process of toggling seems to do the trick. A view appears to be held by some that it has something to do with the Macs T2 chip.

Ah, got it Steven. Will try that next time.
I had no problem before the latest Roon update. And this morning, without doing anything, the CPU load went down by itself to normal…go figure.