High resolution files from Qobuz sometimes don't play through RopieeeXL


I have recently bought an Allo Digione Signature Player With Raspberry Pi 4/Ropieee XL. Sometimes I get no sound when playing high resolution files from Qobuz and Tidal via Roon. The track is playing in Roon, but the DX OP light on my Chord M-Scaler is turned off (the light turns on when an input signal is detected and indicates the resolution of the input file).

I conclude from this that the issue is probably with the Allo Digione Signature Player/Ropieee XL. Sometimes the tracks that don’t play do play at other times, and the issue doesn’t seem to be specific to particular sample rates.

Any advice as to how to fix this gratefully received!


  • Huawei 5G Router to Mac Mini 2018 (Chord Shawline Ethernet Cable)
  • Mac Mini 2018 (local audio files on external Sandisk SSD - 1050 Mbps read speed) to English Electric 8switch Ethernet Switch (Chord Shawline Ethernet Cable)
  • English Electric 8switch Ethernet Switch to Allo Digione Signature Player With Raspberry Pi 4 Model B Rev 1.1/Ropieee XL (Chord Shawline Ethernet Cable)
  • Allo Digione Signature Player to Chord M-Scaler (Chord Signature Super ARAY streaming cable - BNC)
  • Chord M-Scaler to Chord Hugo TT2 DAC (WAVE STREAM Premium Dual BNC cables)

I would suggest trying USB, that might fix your issue. Spdif at high sample rates is delicate.

I play high resolution PCM (96/24 or 192/24) from Qobuz and from local files all the time via Ropieee(XL) on Pi2AES-based streamers with S/PDIF, AES, and I2S outputs to a variety of DACs. No issues ever. Could you have a hardware issue? First thing I’d try in your setup would be to remove the M-Scaler and check again. Replacing S/PDIF cables would also be worth trying. If nothing works, I’d start checking the Allo Digione.

Hi @nickharambee
which router do you have exactly, is it the HUAWEI 5G CPE Pro 2?
Just in case that’s your router too, like mine:
How is it connected to the cellular network?

With 5G, LTE, LTE + or auto?
I noticed that LTE+ with inter-band carrier agregation doesn’t work well with Roon. Every time the router connected to a different cell tower, I had dropouts and interruptions, like you did, especially at higher sample rates.
Also mobile communications are a shared medium. At peak times, when many people come home and access the network, a cell tower can be overloaded. If too many consumers are attached to it, performance drops and leads to exactly the symptoms you mentioned.

I no longer have problems with Roon since the following setting:

LTE and only one SINGLE band permanently set to the nearest cell phone tower with enough capacity, which does not fail even at peak times so that the band does not change.

The RSRQ should be as low and the SINR as high as possible.

I use huaCtrl Pro application for checking, here a pic of my connection. With significantly worse values, performance drops can occur from time to time.