High resolution streaming to Devialet isn't lossless


I noticed that if I use a sample rate conversion in Roon then the output is no longer lossless to Devialet. Why is this, any ideas @support?

Without the sample rate conversion everything is fine:

Actually I noticed that this is not related to sample rate conversion at all. I cannot stream any high resolution music lossless to the Devialet. This is happening with the brand new Core Infinity board.

If I disable the DSP, the signal path still indicates that streaming isn’t lossless anymore.

Hey @Petri – this doesn’t have anything to do with DSP.

The Devialet Air protocol has two modes, “Bit Perfect” and “Fixed Output”, and the mode that’s used is determined by Devialet Air. You can read about these modes on Devialet’s website:

AIR ® offers two different set-up options, asynchronous BitPerfect or asynchronous fixed broadband, to ensure the best possible service quality in even the most unreliable network environments. Asynchronous BitPerfect mode provides optimal audiophile-grade conditions: music is transferred from your computer or smartphone to the amplifier with zero alteration to audio samples. This mode of transfer occurs at the exact same rate as Expert Pro digital-analog conversion rather than the speed imposed by your computer. The amplifier therefore dictates computer behavior rather than the opposite, with AIR® intelligence split evenly between the two devices.

The “bit perfect” mode is explained, but “Fixed Output” (or “Fixed Broadband” as they are now calling it) is not.

The basic premise is that if the the machine’s setup/configuration is unable to maintain a certain data rate, Fixed Output Mode can drop information and possibly fidelity as a way to avoid audio dropouts.

@Petri It’s not clear from your post whether you’re using Wifi, but from what we know about these devices, you will consistently get Bitperfect mode playing over gigabit ethernet. Hope that helps!


Thanks @mike

I have used Devialet AIR for years but I have never heard of the “Fixed output” mode before. It’s always nice to learn something new :slight_smile:

Yes, I’m using Wifi at the moment and it has worked very well so far, except this 24/192 kHz issue. I haven’t noticed any stuttering, crackles, dropouts, white noise or other issues.

I cannot use hardwired connection between Roon Server and Devialet because these devices are located in different rooms.

Would you have any suggestions how to make 24/192 kHz streaming work with Wifi? I have Netgear Orbi that creates the Wifi. I have located the Devialet about 20 cm away from the Orbi satellite.

I have Orbi because I cannot use hardwired connection and also because of excellent reviews and recommendation over here:

I used ethernet over power to fill in between rooms and it works well for me. It isn’t always the answer but in my case (smallish house with modern wiring) it was seamless and has been 100% trouble free.

Thanks for this suggestion @Henry_McLeod - I hadn’t even thought about PLC.

One other option is of course to buy a new server and bringing that to the listening room. Problem is that it should be fanless but still have enough power to do upsampling, convolution, PEQ etc. Optimally it should be able to run Roon Server + HQPlayer. There aren’t many turn key solutions for this. I wish the Roon Nucleus could run the HQPlayer but I’m quite sure that won’t happen anytime soon.

This is why we put so much work into the Signal Path feature of Roon. It introduces a lot more transparency.

Yes, that is a very useful feature. Thank you for implementing that so well!

I’m not sure am I allowed to take this topic any further here since I have just joined the Expert Pro Beta Program and that basically prevents me from communicating anything regarding the Core Infinity board. I don’t want to break any rules. I would have so much to say but I’ll send the feedback directly to Devialet. They may then contact you / Roon if needed.

This topic can be closed therefore.