How can I install Roon Server 2.0 in my Synology DS920+

I installed .spk file downloaded from Christopher’s website.

First installed: Legacy Installer(DSM7), The LOGO of Roon in Synology Packet Center was GREY which shows: ROON LEGACY. And then after I installed: Installer for Synlogy DSM7.x(x64), the LOGO turned white and shows: ROON as follow
截屏2023-10-12 20.05.09
截屏2023-10-12 20.18.16

But now the question is because the APP on my iPad is version 2.0, I cannot connect or control the Roon Server with my iPad or Mac, because the system shows the Synology runs version 1.8 LEGACY.

Did I do something wrong?

There are two versions on there, and you’ve clicked the arrow to show the Legacy installer. You’ll want to click the top link “Installer for Synology DSM 7.x (x64)”.

If you want to keep 1.8 Legacy - You can download the 1.8 Legacy app for your device. However, this is an old version now.

To use 2.0 - I’d remove both instances on ROON (if there are two). Restart the NAS, and then install the correct version.

Download links for your Roon Remote (Legacy):

iOS App Store

Android Play Store
Android Manual Install (Link to APK)

1 Like

Actually I tried to install “Installer for Synology DSM 7.x (x64)” first. But failed several times, the system shows there is some file missing youat the last step. I will show you the notification when I go back to my computer.

Thank you very much!

I uninstalled and rebooted my Synology and tried to install “Installer for Synology DSM 7.x (x64)” on different computer (MAC and Windows), it always failed.the system shows as follow. I’m sure the file is OK because I downloaded it several times.

截屏2023-10-12 20.05.09

I’m sure I did something wrong, but I donut know where…

SPEC of my Synology
model: DS920+
CPU:INTEL Celeron J4125
DSM version:DSM 7.2-64570 Update 1

Ridiculous question, I know, but…Have you tried rebooting your NAS, which should clear out your /tmp directory?

1 Like

Yes I had reboot the Synology, but still cannot install the .apk. But it’s strange that I can install the same .apk file in virtual DSM… I donnot know what’s wrong with my original DSM system.

I recommend reaching out to @crieke

Yes you are right, thank you

How are you getting with this? Wonder if you can download the file on another machine?

YES, I tried that way.

Finally I successally install Roon un Container Manager. Enjoying it now.

Thank you for writing.

1 Like