How do I install the wifi adaprter drivers on PI3?


I am a windows Roon user. In the past I have had some experience with linux Ubuntu and have been installing Roonbridge on my Raspeberry Pi3…

So far following the post instructions on Roon Bridge for ARM: a beginner’s guide to Raspberry Pi and Cubox-i

I have bee able to:

  1. Install Raspbian Jessie Lite.
  2. Install Roonbridge.
  3. I have a DAC+ PRO… the HAT configuration is set to dtoverlay=iqaudio-dacplus
  4. Roon already sees the Pi3 as a zone on the network.
  5. Enter the code strings for the wifi network id and key …

Regarding the wifi connection I have donre the following and still does not connect to the network on wifi…

opened ssh the following…

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

at the bottom of the file (use your arrow keys to navigate), add this text:


Then saver CTR-x and yes.

The verified the connection by issuing

ifconfig wlan0

The result is…

wlan0 Link encap:Ethernet HWaddr b8:27:eb:4f:1b:d3
inet addr: Bcast: Mask:
inet6 addr: fe80::8829:d782:3a54:dc9e/64 Scope:Link
RX packets:72343 errors:0 dropped:1397 overruns:0 frame:0
TX packets:234 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:71950586 (68.6 MiB) TX bytes:32142 (31.3 KiB)

The encap states its ethernet… and according to the tutorial linked at the begining if the inet addr showed address, th wifi should work… I see that “inet6 addr” shows the correct ip for the PI3, but still when I disconnect the ethernet… I get no network connection…

I verified if the wifi dongle was being recognized by the PI3 according to this guide …

and the result shows that the ralink-rt5370 is present on the PI3…

So what is wrong? what to do?


What happens when you reboot the Pi without the Ethernet cable? Does it respond to the wlan IP?

I just read a different string syntax concerning the wifi setup…

ssid=“Your SSID Here”
proto=RSN key_mgmt=WPA-PSK pairwise=CCMP
TKIP group=CCMP TKIP psk=“YourPresharedKeyHere”

Like any sensible wifi setup, myne has a security key which has been entered already.


When booted without ethernet connection. NO it does not… neither it shows on the network advanced IP scanner, or on the Roon as a zone…

Did you notice this lower down in the thread you referenced this solved my problem which seems similar to yours.

criekeChristopher RiekeCommunity: Chief TinkererMay 31
When I setup my wifi on the pi I use the wpa_passphrase command:
You can test the output by entering

pi@raspberrypi:~ $ wpa_passphrase “Your-Wifi-Name” “Password”
pi@raspberrypi:~ $
You can also directly output this into a file (e.g. ~/my_wifi.conf). The “~” indicates your home folder.

pi@raspberrypi:~ $ wpa_passphrase “Your-Wifi-Name” “Password” > ~/my_wifi.conf
Then just replace the wifi config with this new file by:

pi@raspberrypi:~ $ sudo cp ~/my_wifi.conf /etc/wpa_supplicant/wpa_supplicant.conf
Restart your network device (or reboot the pi):

pi@raspberrypi:~ $ sudo ifdown wlan0
pi@raspberrypi:~ $ sudo ifup wlan0
3 Replies1 LikeReply

Thanks philr.

I am handy but not as knowledgeable as intrepid.

Seems you stated on the same boat.

After some fiddling I was able to fix the situation…

Concerning the WIFI using an external adapter I fixed it using the info provided in here by fellow Roon user Nikipore. BIG THANKS

Specifically that if an external wifi adapter is to be used, an additoin to the wifisetup has to be performed…

Setup Wi-Fi
I recommend not to use Wi-Fi for high resolution audio playback when you can avoid it. Although Roon is very graceful because the clocking takes place in the endpoint, Wi-Fi is often brittle. But if you cannot do without Wi-Fi (which I cannot in my bathroom), here is how to set that up. Scan for wireless networks:

$ iwlist wlan0 scan
Add the following at the end of the file /etc/wpa_supplicant/wpa_supplicant.conf:

$ sudo vi /etc/wpa_supplicant/wpa_supplicant.conf
At this point, wpa-supplicant will normally notice a change has occurred within a few seconds, and it will try and connect to the network. If it does not, manually restart the interface with

$ sudo ifdown wlan0 && sudo ifup wlan0
You can verify if it has successfully connected calling

$ ifconfig wlan0
If the inet addr field has an address beside it, the Pi has connected to the network. If not, check that your password and ESSID are correct.

External Wi-Fi Adapter
In the bathroom, the onboard Wi-Fi reception is so weak that I had to resort to an external Wi-Fi Adapter (TP-Link TL-WN822N). Running ifconfig, it shows up as wlan1, so deactivate onboard Wi-Fi which will free the wlan0 device in favor of the external Wi-Fi adapter upon reboot:

$ sudo vi /etc/modprobe.d/disable-onboard-wifi.conf
blacklist brcmfmac
blacklist brcmutil
$ sudo reboot

1 Like