How do you actually add the LS50W to Roon?

Updated to the latest firmware released this month and have my KEF LS50W speakers switched to the WiFi network.

I don’t see them listed under Roon’s list of audio devices. Is there another place I’m supposed to add these to Roon?


You will only see them in Roon when they are not in standby, are you connecting wirelessly or via Ethernet?
If it is wireless hav you setup the LS50w’s to connect to the same wireless network as your Roon core?
Have you added them in the audio setup tab under settings.

Thanks for the reply - all of those items are indeed as they should be.

I tried a restart of my Roon box which sorted the issue out. It had an uptime of a few months. Must’ve been a networking issue.