How I Got Roon ARC Working Again

Today, when I was getting ready to walk Lucy, my dog, Roon ARC would not play anything and said poor connection when connected to my router. So, I tried the following:

Reset Roon ARC - nothing
Rebooted Roon Nucleus - nothing
Rebooted iPhone 13 Pro Max - nothing
Started walking Lucy - music started playing as soon as phone connected by cellular
Returned home - music stopped when reconnected to WIFI
Rebooted U-Verse router - music playing again


Clearly Lucy has learned a trick or two about Roon and router settings to get her walks sorted :slight_smile:.
Smart dog.


You can also try this:

Go into ARC Settings on your phone, scroll to the bottom, and hit Reset Roon ARC. That has worked for me and other people.

That was the first thing I tried. Didn’t help in my situation, but it would in others. It just depends on what the issue is.

I’m getting a ‘poor connection’ message every time I try to connect to Arc. I’ve tried doing all the resets including the reset arc in settings. I’m getting the same message up. Can anyone help?