How in the heck do I adjust volume in HQPlayer

SO I am using Roon, and I have Roon Server and HQPlayer Desktop on a Mac mini, and I control it with either an iPhone/iPad or my MacBook Pro. I have been hearing such good things about the volume control in HQP I wanted to give it a try. So I did what I think I should do, I set the volume in HQP preferences to a max of -2db and a min of -100db. a restart of everything, including the Roon Server app and Roon still tells me the volume is fixed. I set HQP in Roon to “Device Control” rather than fixed, nothing. Still reports as fixed volume.

Good question - I tend not to use this but just went into a number of my endpoints, tried each one set up with HQ player and I could not get Roon to set the volume.

I remember being able to do this many months ago.

Sorry not to be of any more help, but at least I can repeat your issue.

I’m moving this to HQPlayer section.

I’m running Roon Core and HQPlayer Desktop on a Windows 10 server and controlling it on an iPad. I have volume set to min -16, max 0 in HQPlayer and have selected Device Volume for the HQPlayer Zone (Device Setup) in Roon.

When I click on the volume button in Roon for the HQPlayer Zone I get a slider control between -16 and 0 and the + and - buttons.

Try some other volume settings in HQPlayer and see if that makes the difference. Otherwise I’m not sure what might be different between setups.

Is the volume control active at HQPlayer side? If Direct SDM is enabled, volume control is disabled and set to fixed -3 dBFS.


I do have direct SDM enabled as I have an old mini and am not upsampling to DSD with it. Thanks a lot.

That did it! And it sounds wonderful! I don’t know why, but wow!

1 Like