How to add music from Innuos (Zen mk2) in Roon Nucleus as library

Core Machine (Operating system/System info/Roon build number)
Roon Nucleus.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Innous Zen MK-II - USB out to Berkeley DAC

Description Of Issue
I have 2 hardware devices that can act as Roon Core. I’m running Roon Nucleus as a core. I have setup Innous as a roon endpoint.

I would like to add music which I have ripped on Innous to my library without copying it to Nucleus?

If I stick the IP address of Innous in Network Share location, it does not work. what steps am I missing?

As a side comment, even if you get it to work, it is not the best setup, imho. All music is output from the Roon Core, so if the music was on the Innous it would be first sent over the network to the nucleus, processed and then sent back to the Innous for playback. The closer to the Core the music is located the smoother and quicker operations will be, in my experience.

But, to answer your question. Since, the music is on the Innous, it will be basically like setting up a NAS connection, take a read of the FAQ:’m_having_trouble_setting_up_my_NAS

I did try to set it up like NAS and it did not work, hence the original ticket.


Can you see the sharename you are trying to put into roon from a PC?

Did you try smb?

From the Innuos manual

Due to some networking configurations, your innuOS server may not show on the Computer section. If that’s the case, do the following:

Type smb:// where IP number is the number taken on step 2. Ex: smb://

Hi @sandeep_Kangutkar,

I would suggest trying the smb://IP_ADDRESS notation as @Rugby noted to see if it will help. If you have a username and password set up for that share, have you made sure to enter it into Roon as well?

Thanks for your help folks. I’ll try smb option when I get home. Travelling at this time.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.