How to have more "randomness" for playblack

Hello there

I’ve been using Roon and everything is great. There’s just one thing I find a bit weird. Maybe I am not using it correctly.

I have 503 albums, 7968 tracks and 214 artists.

This is how I use Roon:

I go in Tracks > Focus > Most Played: Show all > Play in the last: …all time and then I click on Played to have “minus Played”

Hence, I can listen to tracks I haven’t played, yet.

The problem is, it seems that Roon plays only the same 10 or 20 different artists. So I click on the thumb down but the artist is still coming up.

So I have a feeling the random algorithm lacks variety. Not sure if you have experienced the same.

Is there a way to improve “randomness” of playback?

The method you describe has no randomness. You are simply playing a Focus selection.

You can introduce a random element in two ways. Either:

Hit the Shuffle icon on the Queue screen after hitting Play on the focussed Tracks as above. This will play only the Tracks in the Focus, but in random order (after the first); or

Instead of Play, select Radio in the Play menu. This will play Tracks based on the Focus including Tracks not in the Focus.

If you turn on Shuffle, remember that it will remain on for that Zone until clicked off. That has tricked me many times.

Thanks for your prompt answer.

What if I want to play “unplayed tracks” in random mode, which settings would you recommend?

Actually, I forgot but I created a bookmark “Remaining songs” with the setting “minus played”. Is there a way to have the possibility to play all shuffle on this bookmark?

Yes. When I Focus on Tracks -Played then the top left Play button becomes Shuffle. I’m unable to upload a screenshot at the moment, but do you see the same ?


Although artist I did a thumb down is still appearing. I’m using Focus from the Tracks menu. Shall I use it from Artist menu, instead?

I still have issues with “randomness”. I use my bookmark -Played but I still have Dream Theater & Dragon Ball Z keep appearing, even after clicking “thumb down”.

also, I have a feeling that only 10-20% of the artists are played in the bookmark.

This shuffle behavior really needs to be changed.

Hello there

Still having issues with randomness. Every time I click Thumb Down it is the same 20 songs popping up in a loop.

Is there something wrong? It looks on the same albums and doesn’t want to switch to others, even by forcing to listen a different album.

So weird.

Yes, I’ve noticed this if my Core has been up for a while, i.e. couple of days with 2-3 hours of music per day.

Perhaps a memory leak?

Rebooting or just dropping Core usually fixes.

Weird because I turn off the computer every night.

Hello @support

Roon radio is definitely broken: it shows only the same 20 tracks.

Could you help?

I made a video where can I send it?