[How To] - HUAWEI HG659 Gateway Router - ARC wont connect to nucleus

I cannot connect ARC to nucleus. I get this network error message. Please help.

“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“218.XXX.XX.XXX”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

1 Like


Thank you for reaching out for assistance with port forwarding. I’ve split your post into a separate thread so the team and other users can assist you more directly.

Typically, errors like the one you see can be caused by a misconfigured Port Forwarding setting, if you are not seeing Ready listed in Roon Settings -> Roon ARC, please look over this guide before proceeding.

If you have reviewed this guide and still have not resolved the issue, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?


1 Like

I have attempted all the recommendations (I think) from the Roon guide but to no avail.

Further info as requested:
Internet Service Provider is Iprimus in Australia
Modem/Router is HUAWEI HG659 Gateway
Roon Core is a Roon Nucleus wired to LAN with Static IP address
Music is accessed fron QNAP 453 NAS wired to LAN with static IP address
No VPN’s etc
I have a Netgear Orbit Wireless Access Point wired to LAN

Thanks Rob


Thanks for the info! I’ve done a bit of research on your specific HG659 router. Here are more specific steps on getting port forwarding setup on your device:

  • Setup a static IP address on either your computer or device that you want to forward a port to (sounds like you’ve already done this with your Nucleus :+1:)
  • Login to your Huawei HG659 router
    • Go to on your browser
    • Log in to modem using username admin and password admin

On the opening page of the router, click the Internet link near the top of the page.

Click the Forwarding link near the left of the page.

Now make sure the following information are handy:

  • Application - the name of your VNC application that will use port forwarding (name of your Nucleus)
  • IP Address - The IP Address to forward to should be the same “static IP address” that you have already setup on your PC (The IP address of your roon core)
  • Application Ports used by your VNC application (Port 55000 or you can create your own port number)

Click the New Port Mapping link near the center of the page.

Click the Add Port Mapping Application link near the center of the page.

Click the New link near the bottom of the page.

Now enter the following settings. Please refer to your VNC application documentation.

  • Name
  • External Port
  • Internal Port
  • Protocol

When you are finished, click the Save button.

This brings you back to the previous screen. Enter the following settings:

  • Mapping Name - the name you want to give this port forwarding setup; no spaces allowed
  • Application - your VNC application
  • Internal Host - your static IP address

When you are finished, click the Save button.

Let me know if the above helps, and if you still run into issues after this! I would also test connecting your core directly to your router as well to see if that helps. :pray:


Thank you. I managed to fix the problem with your instructions. Only difference was with my router is the Add Port Mapping Application is called Add New Port Trigger. Also I have to select an interface option when entering info on the new port mapping page. The only option that worked for me was INTERNET_TR069_ETH_VID_100. All good now, thanks.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.