How to install roon extension

windows 10, core=server,

how to install roon extensions I use the installer on github but get error. I tried 32 bit and 64 bit, no luck I installed in administrator mode and the installations is completed. But no extensions in roon. Still confused how to add extensions.
Still get error :
Starting service…
roon-extension-manager: Unexpected status SERVICE_PAUSED in response to START control.

IMO, Roon extensions are not not quite as easy as they should be. I broke down and installed dietpi (with roon bridge + extension options checked) on a raspberry pi based endpoint. An “extension” is then installed from within the Roon remote application: Settings > extensions. If it’s not working right, they’ll be nothing there to select. Good luck.

It is to difficult to setup an extension. The only thing I want is cd player extension

Have you ever read the thread about this extension?

As it seems you missed it:

Note: This is a Docker based extension, it requires a Docker for Linux installation in order to run.

It is usually easy to install the dockerized version of the Roon Extension Manager on a system that meets the requirements to run the CD Player extension:

I was trying all afternoon now it seems that it uses docker and so only linux, I use win10 maybe that is the problem. So even when I get te manager get to work the cd player will not work. Thx for the information.

I installed docker in windows. I installed cd player. But nothing is showing up in Roon But docker is running and the roon extension manager.

Hi @Tecko71,

I got a similar report about the Extension Manager not being listed after installation on Windows. Can you perform the checks I described here?

Also, are there errors reported in the log file located at:


Unfortunately running a Linux container under Docker for Windows doesn’t work in combination with Roon due to limitations in the networking (same subnet etc).

I stop trying it is not user friendly.

I ran the 0.5.3 installer today for Win64, but it was not successful. One problem seems to be that the path of the application data directory is hardcoded instead of using the environment variable LOCALAPPDATA. Since mine is not on drive C:, the installation failed.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.